Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224514 - rebuilddb needs to be done frequently by hand
Summary: rebuilddb needs to be done frequently by hand
Keywords:
Status: CLOSED DUPLICATE of bug 213963
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 23:52 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-17 12:55:03 UTC


Attachments (Terms of Use)
log file when pup dies. (deleted)
2007-04-10 15:38 UTC, Pablo Figueroa
no flags Details

Description Need Real Name 2007-01-25 23:52:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
In fc6 with updates, rpm frequently hangs while installing or updating,
and often pup crashes while checking for updates.  After doing
   'rpm --rebuilddb'
the installing, updating, or checking via pup returns to normal.

I haven't been able to discover a pattern to reproduce this bug.
Often rpm works just as it should.

Version-Release number of selected component (if applicable):
rpm-4.4.2-32

How reproducible:
Sometimes


Steps to Reproduce:
1.Try to install or update a package.
2.rpm hangs.
3.

Actual Results:
Sometimes rpm hangs (or pup crashes).

Expected Results:
rpm never hangs or crashes while installing or updating.

Additional info:
Here is a bug-buddy file from pup (for what it's worth):

Component: Software Updater
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pup", line 659, in ?
    main()
  File "/usr/sbin/pup", line 655, in main
    pup.run()
  File "/usr/sbin/pup", line 494, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 269, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0x9b2ffe0>
child: <Element 'packagereq' at 0x9b2fed8>

Comment 1 Jeff Johnson 2007-01-26 00:24:27 UTC
Doing --rebuilddb is likely overkill. Try
    rm -f /var/lib/rpm/__db*
to fix problems instead.

Comment 2 Jeff Johnson 2007-01-26 00:32:53 UTC
This appears to be the root cause of your traceback:

    https://lists.dulug.duke.edu/pipermail/yum-devel/2007-January/003091.html

Comment 3 Pablo Figueroa 2007-04-10 15:38:06 UTC
Created attachment 152146 [details]
log file when pup dies.

Comment 4 Pablo Figueroa 2007-04-10 15:39:30 UTC
Comment on attachment 152146 [details]
log file when pup dies.

I tried both commands suggested, but no sucess...  (rpm rebuild and rm -f...)

Comment 5 Pablo Figueroa 2007-04-10 15:40:54 UTC
Comment on attachment 152146 [details]
log file when pup dies.

I tried both commands suggested, but no success...  (rpm rebuild and rm -f...)

Comment 6 Panu Matilainen 2007-07-17 12:55:03 UTC

*** This bug has been marked as a duplicate of 213963 ***


Note You need to log in before you can comment on or make changes to this bug.