Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224505 - Pup crash due to typo in extras/comps.xml
Summary: Pup crash due to typo in extras/comps.xml
Keywords:
Status: CLOSED DUPLICATE of bug 224292
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 23:01 UTC by Jerry James
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-26 15:34:21 UTC


Attachments (Terms of Use)
Pup backtrace (deleted)
2007-01-25 23:01 UTC, Jerry James
no flags Details

Description Jerry James 2007-01-25 23:01:22 UTC
Description of problem:
Pirut just crashed with a python exception (see the attached traceback).  The
root problem turns out to be that somebody mistyped "optional" as "optinoal" in
/var/cache/yum/extras/comps.xml, in the entry for digikamimageplugins.  How do I
report the latter, by the way?  I don't know where or how that file is generated.

Version-Release number of selected component (if applicable):
pirut-1.2.8-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. Install digikamimageplugins (I don't know if this step is necessary, but I
have it installed) from Fedora Extras.
2. Run pup

Actual results:
Pup crashes with the current mistyped extras/comps.xml.

Expected results:
Pup should just skip the digikamimageplugins package and continue normally.

Additional info:
Although the exception is thrown in yum code, "yum upgrade" still works, so I am
reporting this against pup, which does not.

Comment 1 Jerry James 2007-01-25 23:01:22 UTC
Created attachment 146645 [details]
Pup backtrace

Comment 2 Alan Schmidt 2007-01-26 00:29:06 UTC
I do not have digikam nor digikamimageplugins installed, but I get this crash
just the same. My traceback is identical.

Comment 3 Jeremy Katz 2007-01-26 15:34:21 UTC

*** This bug has been marked as a duplicate of 224292 ***


Note You need to log in before you can comment on or make changes to this bug.