Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224501 - emacs-vm problem sending MIME attachments
Summary: emacs-vm problem sending MIME attachments
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs-vm
Version: 6
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Jonathan Underwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 22:37 UTC by Wonmuk Hwang
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: emacs-vm-7.19-5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-03 16:34:55 UTC


Attachments (Terms of Use)
A sample email message showing the above problem (openable in emacs-vm) (deleted)
2007-01-25 22:37 UTC, Wonmuk Hwang
no flags Details

Description Wonmuk Hwang 2007-01-25 22:37:35 UTC
Description of problem:
When sending an email, attachments get sent as a MIME encoded text, so 
the recipient sees the encoded text only, not openable files. Even when 
I send a plain text email (using vm) to myself, it arrives with the following 
in the mail body (apart from the real header)

 From: Wonmuk Hwang <hwm@yogi.tamu.edu>
 MIME-Version: 1.0
 Content-Type: text/plain; charset=us-ascii
 Content-Transfer-Encoding: 7bit
 Message-ID: <17849.11051.179886.655677@yogi.tamu.edu>
 Date: Thu, 25 Jan 2007 16:11:55 -0600
 To: hwm
 X-Mailer: VM 7.19 under Emacs 21.4.1

The above paragraph doesn't appear if I use plain `mail' command in shell
window. If I use 'C-x m' in emacs (that is not use vm), then I get the 
following  paragraph in the mail body:

 From: Wonmuk Hwang <hwm@yogi.tamu.edu>
 To: hwm
 Subject: test

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

Version-Release number of selected component (if applicable):
emacs-21.4-17
emacs-vm-7.19-4.fc6

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
How reproducible: Occurs every time I send any email.

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
Steps to Reproduce:
1. In emacs, do 'M-x vm' (vm window opens)
2. type `m' to compose a message (you can send it to yourself)
3. Below `--text follows this line--', type 'C-c-Ca', 
   and attach any file (pdf, jpg, etc)
4. Type 'C-c-C-c' to send the email.

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%  
Actual results: The email is received as an MIME encoded text 

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
Expected results: Should get just one line that looks like:

  application/pdf                     [Click mouse-2 to save to a file]

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
Additional info:

I never had this problem in FC4 (haven't tried in FC5).

I wonder whether the problem is that vm (or emacs) tries to encode the whole
mail message rather than separately encoding the attachment, resulting in an
encoded email whose MIME type is not determined due to the encoded email header.

Please help, and Thank you very much for your effort for making linux better!!!

Comment 1 Wonmuk Hwang 2007-01-25 22:37:35 UTC
Created attachment 146640 [details]
A sample email message showing the above problem (openable in emacs-vm)

Comment 2 Jonathan Underwood 2007-01-26 11:18:33 UTC
Hi Wonmuk,

I'll try and reproduce this locally. However, can you tell me exactly what your
mail setup is - are you using sendmail, postfix or some other method of sending
your mail. Can you also confirm that the same problem doesn't occur on your
machine using a different mail client set to send mail in the same way (eg.
thunderbird).

Thanks.

Comment 3 Wonmuk Hwang 2007-01-26 15:34:33 UTC
Jonathan,

Thanks for your prompt reply. 

- I am using sendmail.
- I just tried sending an email to myself using evolution (using sendmail),
and correctly received the attachment. In vm, it looks in like

[ICON]JPEG image                          [Click mouse-2 to display image]

Besides, there was no weird in-message header present. So the problem seems
to occur only in vm.

- FYI, after installing FC6, I did 'yum update', so the linux kernel 
  version is: 2.6.19-1.2895.fc6 #1 SMP

Thanks

Comment 4 Jonathan Underwood 2007-02-03 14:02:59 UTC
OK, I have reproduced this, and I think I have a fix. Am testing currently, and
will push updated packages this weekend. Watch this space.

Comment 5 Jonathan Underwood 2007-02-03 16:34:55 UTC
OK, new packages (emacs-vm-7.19-5) have been pushed which hopefully fix this
problem. Closing bug, but do re-open if you still have problems. Thanks again
for the report.


Note You need to log in before you can comment on or make changes to this bug.