Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224463 - Package Manager crashes every time - new install
Summary: Package Manager crashes every time - new install
Keywords:
Status: CLOSED DUPLICATE of bug 224292
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 20:10 UTC by Peter Bullock
Modified: 2014-01-21 22:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-25 20:26:30 UTC


Attachments (Terms of Use)

Description Peter Bullock 2007-01-25 20:10:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20061011 Fedora/1.5.0.7-7.fc6 Firefox/1.5.0.7

Description of problem:
I have installed FC6 three times on this desktop machine and the first time I run Package Manager (yum) it continually crashes.  If I run Package Updater (pirut) it likewise crashes every time.  I have successfully installed FC6 on three other machines (one desktop and two laptops) and do not experience this problem on those machines.  I have reinstalled a clean install three times completely removing and replacing all partitions on the machine and formatting the newly created partitions.  This is the cleanest install I can think of, but the Package Manager is failing every time "new out of the box".

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2798.fc6

How reproducible:
Always


Steps to Reproduce:
1. Clean install FC6 - customized to packages I wish to select. 
2. Erase all existing partitions and re-partition and re-format drive
3. This machine is equipped with a pair of 250 GB IDE drives which I am configuring as a RAID 0 mirrored device.
4. As soon as the clean install is complete, I attempt to start either the Package Manager or Software Update and get the crash - which appears to me (from what I can determine) to be the same problem.

Actual Results:
Package Manager (or Package Updater) crashes every time.

Expected Results:
The Package Manager (or Updater) window should have appeared.

Additional info:
Crash Dump from the Package Manager crash:
Component: Software Manager
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 445, in ?
    main()
  File "/usr/sbin/pirut", line 441, in main
    pm.run()
  File "/usr/sbin/pirut", line 350, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 365, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
self: Graphics
package: digikam
type: optinoal
packagelist_elem: <Element 'packagelist' at 0x9f150f8>
child: <Element 'packagereq' at 0x9f0b5d8>


Crash Dump from the Software Updater:
Component: Software Updater
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pup", line 573, in ?
    main()
  File "/usr/sbin/pup", line 569, in main
    pup.run()
  File "/usr/sbin/pup", line 415, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 193, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
self: Graphics
package: digikam
type: optinoal
packagelist_elem: <Element 'packagelist' at 0x96b4050>
child: <Element 'packagereq' at 0x9693f50>

Comment 1 Jeremy Katz 2007-01-25 20:26:30 UTC

*** This bug has been marked as a duplicate of 224292 ***


Note You need to log in before you can comment on or make changes to this bug.