Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224459 - open rpmdb crashes
Summary: open rpmdb crashes
Keywords:
Status: CLOSED DUPLICATE of bug 224292
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 19:56 UTC by Oswaldo David Gómez Socorro
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-25 20:12:34 UTC


Attachments (Terms of Use)

Description Oswaldo David Gómez Socorro 2007-01-25 19:56:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.0.9) Gecko/20061221 Fedora/1.5.0.9-1.fc5 Firefox/1.5.0.9

Description of problem:
Component: Software Manager
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 390, in ?
    main()
  File "/usr/sbin/pirut", line 386, in main
    pm.run()
  File "/usr/sbin/pirut", line 299, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 310, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 150, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 367, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
self: Graphics
package: digikam
type: optinoal
packagelist_elem: <Element 'packagelist' at 0xb385cb30>
child: <Element 'packagereq' at 0xb385cab8>

Version-Release number of selected component (if applicable):
pirut-1.0.3-0.fc5

How reproducible:
Always


Steps to Reproduce:
1.Invoke Add/Remove Software in Gnome, as usual 
2.Superuser password given when required
3.Package Manager window opened in the background while "Retrieving software information" progress bar dialog showed up in front.
4. An Exception Occurred dialog appeared showing a log of the failure and suggesting to post the bug.
5. After hitting the Exit button, the whole thing closed.

Actual Results:
The application was terminated

Expected Results:
As usual, after retrieving the software information, the main Package Manager window were usable to install, upgrade or deinstall software

Additional info:

Comment 1 Jeremy Katz 2007-01-25 20:12:34 UTC

*** This bug has been marked as a duplicate of 224292 ***


Note You need to log in before you can comment on or make changes to this bug.