Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224442 - tzdata inverts plusses and minuses for gmt relative timezones
Summary: tzdata inverts plusses and minuses for gmt relative timezones
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: tzdata
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Machata
QA Contact:
URL:
Whiteboard:
: 808777 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 18:52 UTC by Tom Wood
Modified: 2015-05-05 01:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-01 16:13:48 UTC


Attachments (Terms of Use)

Description Tom Wood 2007-01-25 18:52:01 UTC
Description of problem:


Version-Release number of selected component (if applicable): tzdata-2006p-1
.fc6

How reproducible: Everytime


Steps to Reproduce:
1. Run "system-config-date" and select Time Zone tab.
2. Select GMT-5 to emulate Eastern Standard Time in the US (no DST)
3. Watch as time on system now ahead 10 hours.
  
Actual results:  You get GMT + 5 hours, not GMT - 5 hours.


Expected results:  GMT - 5 hours, which emulates Eastern Standard Time without
the DST changeover.


Additional info:

Comment 1 Petr Machata 2007-02-01 16:13:48 UTC
Excerpt from tzdata sources:

# We use POSIX-style signs in the Zone names and the output abbreviations,
# even though this is the opposite of what many people expect.
# POSIX has positive signs west of Greenwich, but many people expect
# positive signs east of Greenwich.  For example, TZ='Etc/GMT+4' uses
# the abbreviation "GMT+4" and corresponds to 4 hours behind UTC
# (i.e. west of Greenwich) even though many people would expect it to
# mean 4 hours ahead of UTC (i.e. east of Greenwich).

So here we go, POSIX...

Comment 2 Petr Machata 2012-04-02 18:57:08 UTC
*** Bug 808777 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.