Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224433 - mock crashes with the --configdir switch
Summary: mock crashes with the --configdir switch
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Hosted Projects
Classification: Retired
Component: mock
Version: unspecified
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Clark Williams
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 17:57 UTC by Carl Roth
Modified: 2013-01-10 04:10 UTC (History)
1 user (show)

Fixed In Version: 0.6.13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-24 17:06:10 UTC


Attachments (Terms of Use)
Patch to fix --configdir handling in mock (deleted)
2007-01-25 20:41 UTC, Carl Roth
no flags Details | Diff

Description Carl Roth 2007-01-25 17:57:22 UTC
Description of problem:

Mock isn't able to use the --configdir switch.

When I run it, it crashes with

Traceback (most recent call last):
  File "/usr/bin/mock", line 995, in ?
    main()
  File "/usr/bin/mock", line 941, in main
    if config_path != "/etc/mock" and os.file.exists("/etc/mock/defaults.cfg"):
AttributeError: 'module' object has no attribute 'file'

This looks like a Python bug -- the 'os.file.exists' should probably be
'os.path.exists'.

Version-Release number of selected component (if applicable):

mock-0.6.10-1.fc6

How reproducible:

Always

Steps to Reproduce:
1. Invoke mock with the --configdir switch
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Carl Roth 2007-01-25 20:41:10 UTC
Created attachment 146622 [details]
Patch to fix --configdir handling in mock

Comment 2 Clark Williams 2007-02-24 17:06:10 UTC
This was fixed in the 0.6.12 timeframe



Note You need to log in before you can comment on or make changes to this bug.