Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224428 - Bug prevents updating or downloading of optional functions./accessories
Summary: Bug prevents updating or downloading of optional functions./accessories
Keywords:
Status: CLOSED DUPLICATE of bug 224292
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 6
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 17:20 UTC by Jon Foster
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-25 17:21:54 UTC


Attachments (Terms of Use)
Error message when pirut add/remove programs function is called (deleted)
2007-01-25 17:20 UTC, Jon Foster
no flags Details

Description Jon Foster 2007-01-25 17:20:31 UTC
Description of problem:
When activating the add/remove software function, the following error message is
provided:

Component: Software Manager
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 445, in ?
    main()
  File "/usr/sbin/pirut", line 441, in main
    pm.run()
  File "/usr/sbin/pirut", line 350, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 365, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
self: Graphics
package: digikam
type: optinoal
packagelist_elem: <Element 'packagelist' at 0xa6a70f8>
child: <Element 'packagereq' at 0xa69d5d8> 

This prevents anyone from downloading or installing updates or optional
accessories from the install disc.

Comment 1 Jon Foster 2007-01-25 17:20:31 UTC
Created attachment 146585 [details]
Error message when pirut add/remove programs function is called

Comment 2 Michael Schwendt 2007-01-25 17:21:54 UTC

*** This bug has been marked as a duplicate of 224292 ***


Note You need to log in before you can comment on or make changes to this bug.