Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224424 - NFS mishandles dentries during create style operations
Summary: NFS mishandles dentries during create style operations
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Peter Staubach
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 16:55 UTC by Peter Staubach
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-15 16:18:42 UTC


Attachments (Terms of Use)
Proposed patch (deleted)
2007-01-25 17:05 UTC, Peter Staubach
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0791 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 6 2007-11-14 18:25:55 UTC

Description Peter Staubach 2007-01-25 16:55:49 UTC
Description of problem:

The NFS client can double drop dentries if an error occurs during the
create process.

This problem was discovered by doing code inspection while working
on another bug, 128616 for RHEL-3.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Peter Staubach 2007-01-25 17:04:43 UTC
The problem is that the NFS client calls a routine called nfs_instantiate()
to instantiate dentries.  This routine will d_drop() the dentry if it can
not instantiate the dentry.  The problem is that the NFS client also needs
to d_drop() the dentry is any other errors occur during the process of
creating a new file, directory, special device, or symbolic link too.

This d_drop() support should only live in one place to avoid the possibility
of calling it incorrectly.

Comment 2 Peter Staubach 2007-01-25 17:05:53 UTC
Created attachment 146583 [details]
Proposed patch

Comment 3 RHEL Product and Program Management 2007-01-25 17:11:56 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 RHEL Product and Program Management 2007-05-22 17:02:07 UTC
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.

Comment 5 Jason Baron 2007-06-25 20:26:24 UTC
committed in stream U6 build 55.12. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/


Comment 8 errata-xmlrpc 2007-11-15 16:18:42 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html



Note You need to log in before you can comment on or make changes to this bug.