Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224411 - kickpim is a kicker applet but install libkickpim.so in %{_libdir}.
Summary: kickpim is a kicker applet but install libkickpim.so in %{_libdir}.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kickpim
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 16:23 UTC by Laurent Rineau
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-25 16:30:49 UTC


Attachments (Terms of Use)

Description Laurent Rineau 2007-01-25 16:23:38 UTC
Description of problem:
kickpim is a kicker applet. However, it installs a .so and a .la 
in %{_libdir}. Was is more, the name of the library is not standard.

Version-Release number of selected component (if applicable):
kickpim-0.5.3-9.fc5.3, kickpim-0.5.3-10 from devel too.

Steps to Reproduce:
1. Install kickpim from FE repo.
2. rpm -ql kickpim | grep lib
  
Actual results:
/usr/lib/libkickpim.la
/usr/lib/libkickpim.so


Expected results:
/usr/lib/kde3/kickpim_panelapplet.la
/usr/lib/kde3/kickpim_panelapplet.so


Note: the spec file have macros that call "rpm -q" during the build.
  1/ This package will have difficulties to pass the mass review process at 
FUDcon.
  2/ I am surprised that the Fedora build system allows such a thing.

Comment 1 Laurent Rineau 2007-01-25 16:26:17 UTC
(In reply to comment #0)
> Note: the spec file have macros that call "rpm -q" during the build.

Forget that note. I was not reading the actual spec file. :-(


Comment 2 Rex Dieter 2007-01-25 16:30:49 UTC
libkickpim.la, libkickpim.so are loadable modules, not shared libraries, 
similar to the libkdeinit_*.so modules in koffice.

Agreed, it *should* be using something better along the lines of what you 
suggested, but I'd argue that's a relatively minor issue to be taken upstream, 
not particularly interesting/relevant to fedora's packaging of it.

Comment 3 Laurent Rineau 2007-01-25 17:14:10 UTC
(In reply to comment #2)
> libkickpim.la, libkickpim.so are loadable modules, not shared libraries, 
> similar to the libkdeinit_*.so modules in koffice.

I know. That's why it SHOULD (not MUST) be in %{_libdir}/kde3/ like other 
kicker applet modules.

Upstream seems dead: no release since 2004, whereas it has 18 open bugs and 28 
open RFE in the Sourceforge tracker. I have remove kickpim from my system.



Note You need to log in before you can comment on or make changes to this bug.