Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224401 - Package Updater fails on new FC6 installation
Summary: Package Updater fails on new FC6 installation
Keywords:
Status: CLOSED DUPLICATE of bug 224292
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: i386
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 15:52 UTC by John Jelatis
Modified: 2014-01-21 22:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-25 17:39:30 UTC


Attachments (Terms of Use)
bug report generated by Package Updater failure (deleted)
2007-01-25 15:52 UTC, John Jelatis
no flags Details

Description John Jelatis 2007-01-25 15:52:25 UTC
Description of problem:

Package Updater fails on new FC6 installation.
Floating cursor over toolbar icon brings up baloon that says
"13 updates available"

Selecting "View Updates" option brings up window with title
"Retrieving update information"
displays progress bar, and pops up error window
"Exception occurred"
Window contents:
Component: Software Updater
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pup", line 659, in ?
    main()
  File "/usr/sbin/pup", line 655, in main
    pup.run()
  File "/usr/sbin/pup", line 494, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 269, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0x99cd068>
child: <Element 'packagereq' at 0x99c4f68>

I selected option "Save to file"; file is attached to this report.


Various errors, including


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Run Package Updater from toolbar on top of default GUI screen
2. Select View Updates
3.
  
Actual results: see above


Expected results: a list of selectable updates and option to apply?


Additional info: This is happening on many systems in a classroom setting,
on clean/new installations from the latest non-beta ISO,
"For x86-compatible (32-bit)
6722f95b97e5118fa26bafa5b9f622cc7d49530c  FC-6-i386-DVD.iso"
(downloaded from:
http://fedoraproject.org/wiki/Distribution/Download#head-e82fd6bdaa84a16e71fe2bdb732c67258e63428b
Confirmed SHA1 checksum of ISO before burning installation DVDs)

Comment 1 John Jelatis 2007-01-25 15:52:26 UTC
Created attachment 146569 [details]
bug report generated by Package Updater failure

Comment 2 Michael Schwendt 2007-01-25 17:39:30 UTC

*** This bug has been marked as a duplicate of 224292 ***


Note You need to log in before you can comment on or make changes to this bug.