Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224385 - Right clicking an object does not select that object
Summary: Right clicking an object does not select that object
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: 389
Classification: Retired
Component: Directory Console
Version: 1.0.4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks: 389_1.3.0
TreeView+ depends on / blocked
 
Reported: 2007-01-25 14:56 UTC by Jeff Strunk
Modified: 2015-11-12 22:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-12 22:52:23 UTC


Attachments (Terms of Use)

Description Jeff Strunk 2007-01-25 14:56:15 UTC
Description of problem:
When right clicking an object to get to the context menu, the context menu that
pops up is for the last object selected. This could cause accidental deletions
and changes of the wrong objects.

Version-Release number of selected component (if applicable):
1.0.4-1

How reproducible:
Always

Steps to Reproduce:
1. Select an object
2. Right click a different object and click properties
3. Notice that the first object is the one opened.
  
Actual results:
The menu applies to the previously selected object.

Expected results:
The menu applies to the right clicked object.

Additional info:
$ java -version
java version "1.5.0_10"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_10-b03)
Java HotSpot(TM) Client VM (build 1.5.0_10-b03, mixed mode, sharing)

Comment 1 Martin Kosek 2012-01-04 13:47:24 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/135

Comment 2 mreynolds 2014-09-19 21:05:33 UTC
Fixed upstream.

Comment 3 Noriko Hosoi 2015-11-12 22:52:23 UTC
Closing this bug as duplicate of 1173281.

Somehow, bugzilla does not accept the request.  Thus, just close this as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.