Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224383 - yum-3.0.3-1.fc6 doesn't support grouplist
Summary: yum-3.0.3-1.fc6 doesn't support grouplist
Keywords:
Status: CLOSED DUPLICATE of bug 224292
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 14:40 UTC by H.J. Lu
Modified: 2014-01-21 22:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-25 18:33:27 UTC


Attachments (Terms of Use)

Description H.J. Lu 2007-01-25 14:40:16 UTC
[root@lake build-x86_64-linux]# yum grouplist
Loading "installonlyn" plugin
Setting up Group Process
Setting up repositories
core                      100% |=========================| 1.1 kB    00:00     
personal                  100% |=========================| 1.1 kB    00:00     
extras                    100% |=========================| 1.1 kB    00:00     
updates                   100% |=========================| 1.2 kB    00:00     
comps.xml                 100% |=========================|  64 kB    00:01     
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 94, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 356, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 213, in doCommand
    GroupCommand.doCommand(self, base, basecmd, extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 201, in doCommand
    base.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
yum.comps.CompsException
[root@lake build-x86_64-linux]#

Comment 1 H.J. Lu 2007-01-25 14:48:46 UTC
It is caused by

bash-3.1$ grep optinoal /var/cache/yum/extras/comps.xml 
      <packagereq type="optinoal">digikamimageplugins</packagereq>
                        ^^^^^^^^

Comment 2 Jacek Piskozub 2007-01-25 15:34:33 UTC
One of multiple dupes of bug 224292.

Comment 3 Jeremy Katz 2007-01-25 18:33:27 UTC

*** This bug has been marked as a duplicate of 224292 ***


Note You need to log in before you can comment on or make changes to this bug.