Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224376 - Package manager Has exception Component: Software Manager Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException Traceback (most recent call last): File "/usr/sbin/pirut", line 453, in ? main() File "/usr/sbin/pirut", line 44...
Summary: Package manager Has exception Component: Software Manager Summary: TB8a9160c...
Keywords:
Status: CLOSED DUPLICATE of bug 224292
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 14:18 UTC by Charlie Farrow
Modified: 2014-01-21 22:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-25 17:38:06 UTC


Attachments (Terms of Use)

Description Charlie Farrow 2007-01-25 14:18:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
When I try to open the package manager, I get an unhandled exception as follows. This makes the gnome package manager unusable.




Version-Release number of selected component (if applicable):
Unknown

How reproducible:
Always


Steps to Reproduce:
1. Click On Applications, then on Add ? remove Software.
2. The Package Manager starts and then produces this exception.
3.

Actual Results:
The above exception occours and you have to exit the program.

Expected Results:
The Package managaer should start to allow the modification of installed programs.

Additional info:
Component: Software Manager
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 453, in ?
    main()
  File "/usr/sbin/pirut", line 449, in main
    pm.run()
  File "/usr/sbin/pirut", line 358, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 373, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0x9cbd080>
child: <Element 'packagereq' at 0x9cb2f98>

Comment 1 Jonathan 2007-01-25 14:23:57 UTC
I also encountered exactly the same problem.

Comment 2 Michael Schwendt 2007-01-25 17:38:06 UTC

*** This bug has been marked as a duplicate of 224292 ***

Comment 3 Charlie Farrow 2008-08-02 20:16:37 UTC
The original summary for this bug was longer than 255 characters, and so it was truncated when Bugzilla was upgraded. The original summary was:

Package manager Has exception Component: Software Manager  Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException    Traceback (most recent call last):    File "/usr/sbin/pirut", line 453, in ?      main()    File "/usr/sbin/pirut", line 449, in main      pm.run()    File "/usr/sbin/pirut", line 358, in run      self.doRefresh()    File "/usr/sbin/pirut", line 373, in doRefresh      self.reposSetup(pbar)    File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup      self.doGroupSetup()    File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup      self.comps.add(groupfile)    File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add      group = Group(elem)    File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__      self.parse(elem)    File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse      self.parse_package_list(child)    File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in parse_package_list      raise CompsException  CompsException    Local variables in innermost frame:  genre: optinoal  self: Graphics  package: digikam  packagelist_elem: <Element 'packagelist' at 0x9cbd080>  Package manager has exception TB8a9160cb comps.py:143:parse_package_list:CompsException


Note You need to log in before you can comment on or make changes to this bug.