Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224368 - Software updater fails
Summary: Software updater fails
Keywords:
Status: CLOSED DUPLICATE of bug 224292
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General
Version: devel
Hardware: i386
OS: Linux
medium
urgent vote
Target Milestone: ---
Assignee: Bernd Groh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 13:51 UTC by Jens Pol
Modified: 2014-06-18 08:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-28 00:25:39 UTC


Attachments (Terms of Use)
output of bugzilla report (deleted)
2007-01-25 13:51 UTC, Jens Pol
no flags Details

Description Jens Pol 2007-01-25 13:51:52 UTC
Description of problem:
automatic update fails

Version-Release number of selected component (if applicable):
Software Updater

How reproducible:
start autoupdate

Steps to Reproduce:
1.start autoupdate
2.
3.
  
Actual results:
crashes

Expected results:
software update

Additional info:

Comment 1 Jens Pol 2007-01-25 13:51:52 UTC
Created attachment 146538 [details]
output of bugzilla report

Comment 2 Chuck Bloodworth 2007-01-25 18:47:34 UTC
There seem to have been a number of identical bug reports, so I won't file a new
one; I'll just comment here to let you know that I have the same problem, and to
provide some additional information.

This problem is intermittent.  Sometimes the software updates work properly, but
most of the time they fail, with the following crash dump:
------------------------------------------------------------
Component: Software Manager
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 445, in ?
    main()
  File "/usr/sbin/pirut", line 441, in main
    pm.run()
  File "/usr/sbin/pirut", line 350, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 365, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0xa0bb080>
child: <Element 'packagereq' at 0xa09af98>
--------------------------------------------------------

Comment 3 Michael Schwendt 2007-01-28 00:25:39 UTC

*** This bug has been marked as a duplicate of 224292 ***


Note You need to log in before you can comment on or make changes to this bug.