Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224356 - unhandled exception in pup
Summary: unhandled exception in pup
Keywords:
Status: CLOSED DUPLICATE of bug 224292
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 12:34 UTC by Matthias Clasen
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-25 17:20:40 UTC


Attachments (Terms of Use)

Description Matthias Clasen 2007-01-25 12:34:49 UTC
pup just gave me the following exception: 

Component: Software Updater
Summary: TB9a5bb4f4 comps.py:147:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pup", line 668, in <module>
    main()
  File "/usr/sbin/pup", line 664, in main
    pup.run()
  File "/usr/sbin/pup", line 499, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 274, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 151, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.5/site-packages/yum/comps.py", line 343, in add
    group = Group(elem)
  File "/usr/lib/python2.5/site-packages/yum/comps.py", line 61, in __init__
    self.parse(elem)
  File "/usr/lib/python2.5/site-packages/yum/comps.py", line 137, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.5/site-packages/yum/comps.py", line 147, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
child: <Element 'packagereq' at 0x999f080>
packagelist_elem: <Element 'packagelist' at 0x9998f98>
package: digikam

Comment 1 Michael Schwendt 2007-01-25 17:20:40 UTC

*** This bug has been marked as a duplicate of 224292 ***


Note You need to log in before you can comment on or make changes to this bug.