Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224342 - 'software updater' and 'software manager' fails to successfully load
Summary: 'software updater' and 'software manager' fails to successfully load
Keywords:
Status: CLOSED DUPLICATE of bug 224292
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 11:09 UTC by Andrew Gasperotti
Modified: 2014-01-21 22:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-25 17:43:24 UTC


Attachments (Terms of Use)

Description Andrew Gasperotti 2007-01-25 11:09:16 UTC
Description of problem:
'software updater' fails to load successfully
i updated a few packages today (no kernal upgrades)

Note that 'Add/remove Software' (software manager) also fails


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. follow menu items, from gnome desktop, 'Applications' then 'System Tools' and
choose item 'Software Updater'
  
the same error occurs when running yum and yumex


crash dump follows for software updater:
Component: Software Updater
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pup", line 573, in ?
    main()
  File "/usr/sbin/pup", line 569, in main
    pup.run()
  File "/usr/sbin/pup", line 415, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 193, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0x91c9fe0>
child: <Element 'packagereq' at 0x91c9ed8>


crash dump follows for 'Add/remove Software' (software manager):
Component: Software Manager
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 445, in ?
    main()
  File "/usr/sbin/pirut", line 441, in main
    pm.run()
  File "/usr/sbin/pirut", line 350, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 365, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0x93f5080>
child: <Element 'packagereq' at 0x93d5f98>

Comment 1 Andrew Gasperotti 2007-01-25 13:14:23 UTC

can now close this call

i ran 'rpm --rebuilddb' and 'yum clean all' and reran yumex to rebuild cache and
 now all software works

Comment 2 Michael Schwendt 2007-01-25 17:43:24 UTC

*** This bug has been marked as a duplicate of 224292 ***


Note You need to log in before you can comment on or make changes to this bug.