Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224335 - Bare Metal Kickstart for rhel-i386-as-2 do not work
Summary: Bare Metal Kickstart for rhel-i386-as-2 do not work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 500
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 10:23 UTC by Miroslav Suchý
Modified: 2007-07-31 16:31 UTC (History)
1 user (show)

Fixed In Version: 500
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-03 09:22:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Miroslav Suchý 2007-01-25 10:23:13 UTC
Description of problem:
I got error when choose bare metal KS for rhel-i386-as-2 it shout internal
error. I have synced rhn-tool channel, so it is not the same as similar problem
in bug 215892

Version-Release number of selected component (if applicable):
satellite 490

How reproducible:
always

Steps to Reproduce:
1. enter satellite
2. View a List of Kickstart Profiles and choose redhat-advanced-server-i386-qu0
3. choose Bare Metal Kickstart
4. follow the long url - in my case 
http://sputnik-prod.brq.redhat.com/kickstart/ks/org/1x396ef4c82227ba36f5924c8362900e0f/label/redhat-advanced-server-i386-qu0
5. Internal Server Error
  
Actual results:


Expected results:


Additional info:
2007-01-25 08:53:45,295 [TP-Processor3] WARN 
com.redhat.rhn.frontend.servlets.ContextFilter - timezone still null
2007-01-25 08:53:45,308 [TP-Processor3] ERROR
com.redhat.rhn.manager.kickstart.KickstartScheduleCommand - Tools channel not
found!  This means we can't find the rhn-kickstart package.
2007-01-25 08:53:45,311 [TP-Processor3] WARN 
org.apache.struts.action.RequestProcessor - Unhandled Exception thrown: class
java.lang.NullPointerException
2007-01-25 08:53:45,312 [TP-Processor3] ERROR
com.redhat.rhn.frontend.servlets.SessionFilter - Error during transaction.
Rolling back
javax.servlet.ServletException: channelIn is null!
        at
org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
        at
org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
        at
org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)
        at
com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:70)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
        at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:743)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
        at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:136)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
        at
com.redhat.rhn.frontend.servlets.ContextFilter.doFilter(ContextFilter.java:98)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
        at
com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
        at
com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
        at
com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:52)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
        at
com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:88)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
        at
com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
        at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at
org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
        at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
        at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
        at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:300)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:374)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:743)
        at
org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:675)
        at org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:866)
        at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
        at java.lang.Thread.run(Thread.java:568)
Caused by: java.lang.NullPointerException: channelIn is null!
        at
com.redhat.rhn.domain.token.ActivationKey.addChannel(ActivationKey.java:230)
        at
com.redhat.rhn.manager.kickstart.KickstartScheduleCommand.createKickstartActivationKey(KickstartScheduleCommand.java:693)
        at
com.redhat.rhn.manager.kickstart.KickstartSessionCreateCommand.<init>(KickstartSessionCreateCommand.java:66)
        at
com.redhat.rhn.frontend.action.kickstart.KickstartHelper.parseKickstartUrl(KickstartHelper.java:196)
        at
com.redhat.rhn.frontend.action.kickstart.RenderKickstartFileAction.execute(RenderKickstartFileAction.java:54)
        at
org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
        ... 51 more
NULL

Comment 1 Jan Pazdziora 2007-05-02 12:44:01 UTC
Taking over for investigation.

Comment 2 Jan Pazdziora 2007-05-03 09:22:06 UTC
I've now retried this with redhat-advanced-server-i386 and Satellite 5.0.0-28 --
both the kickstart cfg URL, and the whole kickstart of RHEL 2.1 work alright,
both and bare metal and an auto-kickstart (initiated from the WebUI).

Thus, let us assume that this got fixed in the meantime and I'm thus closing
this bug as CURRENTRELEASE.


Note You need to log in before you can comment on or make changes to this bug.