Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224323 - No software update/Addition of new program possible through the GUI
Summary: No software update/Addition of new program possible through the GUI
Keywords:
Status: CLOSED DUPLICATE of bug 224292
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 6
Hardware: noarch
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 09:17 UTC by tsylverberg
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-25 17:15:48 UTC


Attachments (Terms of Use)
dump: Pirut instant crash on package info retrieval (deleted)
2007-01-25 09:49 UTC, An. N
no flags Details

Description tsylverberg 2007-01-25 09:17:16 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Choose Software Update or ADD/Delete program from menu and fill out password

Result:
Component: Software Manager
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 453, in ?
    main()
  File "/usr/sbin/pirut", line 449, in main
    pm.run()
  File "/usr/sbin/pirut", line 358, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 373, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0x18ba090>
child: <Element 'packagereq' at 0x18b8c60>

Comment 1 An. N 2007-01-25 09:49:26 UTC
Created attachment 146513 [details]
dump: Pirut instant crash on package info retrieval

x86_64 t5600 merom

Comment 2 An. N 2007-01-25 09:51:13 UTC
Comment on attachment 146513 [details]
dump: Pirut instant crash on package info retrieval

same here. 

Linux oplaport4 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:39:22 EDT 2006 x86_64
x86_64 x86_64 GNU/Linux

Comment 3 Rui Moura 2007-01-25 12:25:04 UTC
Same here.

Linux yoda.darkside 2.6.19-1.2895.fc6 #1 SMP Wed Jan 10 18:32:37 EST 2007 i686
i686 i386 GNU/Linux


Comment 4 An. N 2007-01-25 15:12:03 UTC
Seems that someone botched the description for one of the packages in the
database (it's near digicam). Where it should've said "optional" it says "optinoal".

Modifying 2 lines of code in /usr/lib/python2.4/site-packages/yum/comps.py
solved my problem (it's a quick and dirty hack, nevertheless).

I guess we need to wait until they correct the typo in the repos.


Comment 5 Michael Schwendt 2007-01-25 17:15:48 UTC

*** This bug has been marked as a duplicate of 224292 ***


Note You need to log in before you can comment on or make changes to this bug.