Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224299 - Yumex version 1.2.2 crashes at startup time.
Summary: Yumex version 1.2.2 crashes at startup time.
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 224332 224457 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 05:16 UTC by Luis Montalvo
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-26 17:56:50 UTC


Attachments (Terms of Use)
Yumex crash dump (deleted)
2007-01-25 05:16 UTC, Luis Montalvo
no flags Details
dump: Yumex instant crash while gathering package info (deleted)
2007-01-25 10:02 UTC, An. N
no flags Details

Description Luis Montalvo 2007-01-25 05:16:57 UTC
Description of problem:

Yumex crashes at startup with the following message:

An unhandled exeption has occured. This is most likely a bug. Please save the
crash dump and file a detailed bug report against yumex.

Version-Release number of selected component (if applicable):

Version: 1.2.2

How reproducible:

Steps to Reproduce:
1. Run yumex.
2.
3.
  
Actual results: Yumex crashes


Expected results: Getting packages update/install list.


Additional info:

Component: yumex
Version: 1.2.2
Summary: TB03120a34 yumexmain.py:1045:_runBackground:CompsException

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1108, in ?
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 541, in __init__
    self.setup_yum()
  File "/usr/share/yumex/yumexmain.py", line 992, in setup_yum
    if self._runBackground( self.yumexbase.load_repo_data, rload ):
  File "/usr/share/yumex/yumexmain.py", line 1045, in _runBackground
    raise self.backgroundThread.exception
CompsException

Local variables in innermost frame:
runfunc: <bound method yumexBase.load_repo_data of <yumex.yumexBase.yumexBase
object at 0x9782b0c>>
args: (False,)
self: <__main__.YumexMainApplication instance at 0x978218c>

Comment 1 Luis Montalvo 2007-01-25 05:16:57 UTC
Created attachment 146497 [details]
Yumex crash dump

Comment 2 Sammy HO 2007-01-25 07:05:15 UTC
I have the same problem who I ypgrade to fc6 from fc5, then use yumex to update
application.

The dump is reproduced herewith:
Component: yumex
Version: 1.2.2
Summary: TB03120a34 yumexmain.py:1045:_runBackground:CompsException

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 181, in on_queueProcess_clicked
    self.setup_yum()
  File "/usr/share/yumex/yumexmain.py", line 992, in setup_yum
    if self._runBackground( self.yumexbase.load_repo_data, rload ):
  File "/usr/share/yumex/yumexmain.py", line 1045, in _runBackground
    raise self.backgroundThread.exception
CompsException

Local variables in innermost frame:
runfunc: <bound method yumexBase.load_repo_data of <yumex.yumexBase.yumexBase
object at 0x8f2becc>>
args: (True,)
self: <__main__.YumexMainApplication instance at 0x8a881ac>




Here is the 2nd dump:
Component: yumex
Version: 1.2.2
Summary: TB03120a34 yumexmain.py:1045:_runBackground:CompsException

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1108, in ?
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 541, in __init__
    self.setup_yum()
  File "/usr/share/yumex/yumexmain.py", line 992, in setup_yum
    if self._runBackground( self.yumexbase.load_repo_data, rload ):
  File "/usr/share/yumex/yumexmain.py", line 1045, in _runBackground
    raise self.backgroundThread.exception
CompsException

Local variables in innermost frame:
runfunc: <bound method yumexBase.load_repo_data of <yumex.yumexBase.yumexBase
object at 0x894332c>>
args: (False,)
self: <__main__.YumexMainApplication instance at 0x849f44c>



Here is the 3rd dump:
Component: yumex
Version: 1.2.2
Summary: TB03120a34 yumexmain.py:1045:_runBackground:CompsException

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1108, in ?
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 541, in __init__
    self.setup_yum()
  File "/usr/share/yumex/yumexmain.py", line 992, in setup_yum
    if self._runBackground( self.yumexbase.load_repo_data, rload ):
  File "/usr/share/yumex/yumexmain.py", line 1045, in _runBackground
    raise self.backgroundThread.exception
CompsException

Local variables in innermost frame:
runfunc: <bound method yumexBase.load_repo_data of <yumex.yumexBase.yumexBase
object at 0x8b0932c>>
args: (False,)
self: <__main__.YumexMainApplication instance at 0x866544c>


Here is the 4th dump:
Component: yumex
Version: 1.2.2
Summary: TB03120a34 yumexmain.py:1045:_runBackground:CompsException

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1108, in ?
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 541, in __init__
    self.setup_yum()
  File "/usr/share/yumex/yumexmain.py", line 992, in setup_yum
    if self._runBackground( self.yumexbase.load_repo_data, rload ):
  File "/usr/share/yumex/yumexmain.py", line 1045, in _runBackground
    raise self.backgroundThread.exception
CompsException

Local variables in innermost frame:
runfunc: <bound method yumexBase.load_repo_data of <yumex.yumexBase.yumexBase
object at 0x976032c>>
args: (False,)
self: <__main__.YumexMainApplication instance at 0x92bc44c>





Comment 3 An. N 2007-01-25 10:02:39 UTC
Created attachment 146515 [details]
dump: Yumex instant crash while gathering package info

Same here. Pirut crashes in a similar manner, so perhaps our package databses
are corrupt?

Linux oplaport4 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:39:22 EDT 2006 x86_64
x86_64 x86_64 GNU/Linux

Comment 4 Bas Mevissen 2007-01-25 14:34:45 UTC
Same here. The "yum update" still works. Also installing packages still works.

Comment 5 An. N 2007-01-25 15:03:04 UTC
Seems that someone botched the description for one of the packages in the
database (it's near digicam). Where it should've said "optional" it says "optinoal".

Modifying 2 lines of code in /usr/lib/python2.4/site-packages/yum/comps.py
solved my problem (it's a quick and dirty hack, nevertheless).


Comment 6 Luis Montalvo 2007-01-26 16:39:54 UTC
Yumex works for me now. I did nothing on my side though.

Comment 7 Bas Mevissen 2007-01-26 16:49:19 UTC
Same here, problem was apparently in the database.
Maybe this can be a reminder to make yum etc. more solid to this kind of
problems. Hopefully FC7 will bring performance and stability improvements in
this respect.

Comment 8 Tim Lauridsen 2007-01-26 17:56:50 UTC
Caused by a typo in the extras comps.xml, changes has been made in yum to avoid
this kind of error.
The typo has also been fixed.

Comment 9 Tim Lauridsen 2007-01-26 17:57:54 UTC
*** Bug 224332 has been marked as a duplicate of this bug. ***

Comment 10 Tim Lauridsen 2007-01-26 17:58:53 UTC
*** Bug 224457 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.