Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224290 - Crash in pirut
Summary: Crash in pirut
Keywords:
Status: CLOSED DUPLICATE of bug 224292
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 6
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 03:10 UTC by Michael Norred
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-25 12:18:04 UTC


Attachments (Terms of Use)
pirut crash (deleted)
2007-01-25 11:57 UTC, Domenico Romano
no flags Details

Description Michael Norred 2007-01-25 03:10:46 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible: Started Add/Remove Spftware from Gnome, during the read of the
 installed software, I received the following crash report:
Component: Software Manager
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 453, in ?
    main()
  File "/usr/sbin/pirut", line 449, in main
    pm.run()
  File "/usr/sbin/pirut", line 358, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 373, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0x9d39110>
child: <Element 'packagereq' at 0x9d39020>



Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Domenico Romano 2007-01-25 11:57:48 UTC
Created attachment 146526 [details]
pirut crash

Comment 2 Michael Schwendt 2007-01-25 12:18:04 UTC
This bug is older than bug 224292, but the other one has inline info
and is in NEEDINFO already.


*** This bug has been marked as a duplicate of 224292 ***


Note You need to log in before you can comment on or make changes to this bug.