Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224272 - Boot message "mdadm: No arrays found in config file"
Summary: Boot message "mdadm: No arrays found in config file"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mdadm
Version: 6
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Doug Ledford
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-24 23:11 UTC by Davide Bolcioni
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 2.6.2-4.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-20 19:35:57 UTC


Attachments (Terms of Use)
mdadm.conf (deleted)
2007-01-24 23:11 UTC, Davide Bolcioni
no flags Details

Description Davide Bolcioni 2007-01-24 23:11:06 UTC
Description of problem: When booting, the message "mdadm: No arrays found in 
config file" appears after the hostname is set. In spite of the message, my MD 
arrays are OK.


Version-Release number of selected component (if applicable):
mdadm-2.5.4-2.fc6

How reproducible:
At every boot.

Steps to Reproduce:
1. Reboot
2.
3.
  
Actual results:
mdadm: No arrays found in config file ... and a heart attack :-)

Expected results:
No such worrisome message.

Additional info: Please see attached mdadm.conf, which was generated by 
Anaconda upon upgrading from Fedora Core 5. The UUIDs match.

Comment 1 Davide Bolcioni 2007-01-24 23:11:06 UTC
Created attachment 146472 [details]
mdadm.conf

Comment 2 Curtis Doty 2007-02-10 04:09:49 UTC
I see this too. At first, I though this was a bug in the initscripts. But a
closer look makes me thing it is in mdadm.c.

This bug appears to occurs when you have md devices that are already loaded
properly in the kernel initrd. *And* when your /etc/mdadm.conf exists (i.e.
anaconda was nice enough to set it up for you automatically).

Now you don't want to delete the /etc/mdadm.conf since it is needed for
mdmonitor functionality--very important. But...

mdadm.c appears to generically spit out this error when it *really* means that
/dev/md0 didn't *need* to be running--because it was already.

Maybe a patch to mdadm.c to make it quiet when the auto-assemble routines run,
but md devices are already running?

Comment 3 Doug Ledford 2007-07-03 17:10:24 UTC
I'm preparing a new version of mdadm for an update.  It will be 2.6.2-2 (or
later).  I don't see this behavior with that version.  Instead, if you call
mdadm -As without a specific raid device, it silently ignores any that are
running.  If you call mdadm -As /dev/md<blah>, it will report:

[root@firewall lost+found]# mdadm -As /dev/md0
mdadm: device /dev/md0 already active - cannot assemble it
[root@firewall lost+found]# 

So, I believe this will be resolved by the update.  If I'm wrong, please reopen.

Comment 4 Fedora Update System 2007-07-05 19:12:20 UTC
mdadm-2.6.2-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2007-07-09 15:47:58 UTC
mdadm-2.6.2-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2007-07-10 06:42:20 UTC
mdadm-2.6.2-4.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2007-07-20 19:35:22 UTC
mdadm-2.6.2-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.