Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224248 - Frysk seems to get some frame addresses wrong
Summary: Frysk seems to get some frame addresses wrong
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: frysk
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Andrew Cagney
QA Contact: Len DiMaggio
URL:
Whiteboard:
Depends On: 224211
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-24 20:43 UTC by Stepan Kasal
Modified: 2007-11-30 22:07 UTC (History)
9 users (show)

Fixed In Version: RHEA-2007-0592
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 18:05:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2007:0592 normal SHIPPED_LIVE frysk enhancement update 2007-10-30 22:45:30 UTC

Description Stepan Kasal 2007-01-24 20:43:26 UTC
+++ This bug was initially created as a clone of Bug #224211 +++

frysk-0.0.1.2006.12.22.rh1-1.fc6

mcvet@warbird:~ >> fstack 2704
Task #2704
#0 0x2aaaab1612f5 in waitpid ()
#1 0x450b8f in _start ()                         <-- doesn't match pstack
#2 0x4369ce in wait_for ()
#3 0x42a804 in execute_command_internal ()
#4 0x42a873 in execute_command_internal ()
#5 0x42b2df in execute_command ()
#6 0x42a84b in execute_command_internal ()
#7 0x42b2df in execute_command ()
#8 0x42a84b in execute_command_internal ()
#9 0x42b2df in execute_command ()
#10 0x42a84b in execute_command_internal ()
#11 0x429df3 in execute_command_internal ()
#12 0x437851 in _start ()                        <-- ditto
#13 0x438f59 in _start ()                        <-- ditto
#14 0x429c64 in execute_command_internal ()
#15 0x42b2df in execute_command ()
#16 0x429be8 in execute_command_internal ()
#17 0x42b2df in execute_command ()
#18 0x41b2ae in reader_loop ()
#19 0x41ae09 in main ()
#20 0x2aaaab0eaa44 in __libc_start_main ()
#21 0x418ca9 in _start ()

mcvet@warbird:~ >> pstack 2704
#0  0x00002aaaab1612f5 in waitpid () from /lib64/libc.so.6
#1  0x0000000000434c4f in get_job_by_pid ()
#2  0x00000000004369ce in wait_for ()
#3  0x000000000042a804 in execute_command_internal ()
#4  0x000000000042a873 in execute_command_internal ()
#5  0x000000000042b2df in execute_command ()
#6  0x000000000042a84b in execute_command_internal ()
#7  0x000000000042b2df in execute_command ()
#8  0x000000000042a84b in execute_command_internal ()
#9  0x000000000042b2df in execute_command ()
#10 0x000000000042a84b in execute_command_internal ()
#11 0x0000000000429df3 in execute_command_internal ()
#12 0x0000000000428451 in new_fd_bitmap ()
#13 0x0000000000429359 in new_fd_bitmap ()
#14 0x0000000000429c64 in execute_command_internal ()
#15 0x000000000042b2df in execute_command ()
#16 0x0000000000429be8 in execute_command_internal ()
#17 0x000000000042b2df in execute_command ()
#18 0x000000000041b2ae in reader_loop ()
#19 0x000000000041ae09 in main ()

-- Additional comment from jkratoch@redhat.com on 2007-01-24 14:13 EST --
Created an attachment (id=146435)
Preliminary patch

Result:
Task #30054
#0 0xb94402 in __kernel_vsyscall ()
#1 0x19e9a3 in waitpid ()
#2 0x8079606 in [unknown]
#3 0x807b438 in wait_for ()
#4 0x806ea7a in execute_command_internal ()
#5 0x806e994 in execute_command_internal ()
#6 0x806f493 in execute_command ()
#7 0x806e95e in execute_command_internal ()
#8 0x806f493 in execute_command ()
#9 0x806e95e in execute_command_internal ()
#10 0x806f493 in execute_command ()
#11 0x806e95e in execute_command_internal ()
#12 0x806e048 in execute_command_internal ()
#13 0x806c3df in [unknown]
#14 0x806d3e3 in [unknown]
#15 0x806dc67 in execute_command_internal ()
#16 0x806f493 in execute_command ()
#17 0x806dbca in execute_command_internal ()
#18 0x806f493 in execute_command ()
#19 0x805ed21 in reader_loop ()
#20 0x805e817 in main ()
#21 0x125dec in __libc_start_main ()
#22 0x805c471 in _start ()


-- Additional comment from jkratoch@redhat.com on 2007-01-24 15:15 EST --
Committed to CVS as:
2007-01-24  Jan Kratochvil  <jan.kratochvil@redhat.com>

        * src/elfxx.c (lookup_symbol): Fix false preceding zero-sized function
        resolving (printed `_start' symbols for stripped binaries).

Comment 1 Stepan Kasal 2007-01-24 22:55:27 UTC
The issue is fixed in frysk-0.0.1.2006.12.22.rh1-5.el5 .

Comment 2 RHEL Product and Program Management 2007-01-24 23:01:11 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Andrew Cagney 2007-05-07 18:12:39 UTC
Fix committed.  Testing covered by funit testsuite.

Comment 9 errata-xmlrpc 2007-11-07 18:05:52 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0592.html



Note You need to log in before you can comment on or make changes to this bug.