Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224224 - Gaim crashes on (not) sending video
Summary: Gaim crashes on (not) sending video
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pidgin
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-24 17:58 UTC by Michal Babej
Modified: 2013-07-31 23:10 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-09 16:11:51 UTC


Attachments (Terms of Use)
coredump (deleted)
2007-01-24 17:58 UTC, Michal Babej
no flags Details
backtrace from gdb. (deleted)
2007-03-26 14:52 UTC, Michal Babej
no flags Details
gdb backtrace (deleted)
2007-03-28 11:20 UTC, Michal Babej
no flags Details

Description Michal Babej 2007-01-24 17:58:51 UTC
Description of problem:
I just happened to chat with a friend (through Jabber). Now, i wanted to send
him a video file, so i drag-n-dropped one video file (it was OGG) from the
desktop to the conversation window. Then i realised quickly it's not the right
video, so i pushed "stop". On the other side, right after my actions, he
approved receiving a file, selected a file name, then clicked "save". At that
moment, my gaim crashed. This is 100% reproducible.

Version-Release number of selected component (if applicable):
on both sides gaim-2.0.0-0.28.beta5.el5

How reproducible:
always

Actual results:
crash

i attached a core dump.

Comment 1 Michal Babej 2007-01-24 17:58:53 UTC
Created attachment 146428 [details]
coredump

Comment 3 Warren Togami 2007-01-24 20:32:12 UTC
Please do not file gaim bugs that are closed to outside viewers.

Comment 8 RHEL Product and Program Management 2007-03-21 22:33:58 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 9 Warren Togami 2007-03-21 22:52:30 UTC
http://gaim.sourceforge.net/gdb.php
Please follow the procedure documented on this page to provide a gdb traceback
after installing the matching -debuginfo RPM.

Comment 10 Michal Babej 2007-03-26 14:49:11 UTC
my apologies for sending a coredump instead of backtrace.

Comment 11 Michal Babej 2007-03-26 14:52:17 UTC
Created attachment 150903 [details]
backtrace from gdb.

Comment 12 Michal Babej 2007-03-28 11:20:52 UTC
Created attachment 151107 [details]
gdb backtrace

the last bt was missing some symbols

Comment 13 Warren Togami 2007-04-03 03:03:41 UTC
http://people.redhat.com/wtogami/temp/gaim-RHEL5/
Could you please retest with this newer version?

Comment 14 Michal Babej 2007-04-03 10:57:03 UTC
i tested it, still crashes at the same point (si.c:610)

Comment 17 Daniel Riek 2007-06-11 15:09:31 UTC
GAIM / PIDGIN is going to be released asynchronously, but these issues are not
going to be addressed. Closing DEFERRED.

If they are important, they can be re-opened for a future minor release.

Comment 18 Warren Togami 2007-06-11 18:35:06 UTC
Please don't close these bugs as DEFERRED.  CLOSED DEFERRED will make it
disappear from the radar forever.

Comment 19 RHEL Product and Program Management 2007-06-11 18:45:14 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 23 Warren Togami 2007-10-22 14:23:20 UTC
Moving this to be a Fedora bug.

Comment 24 Stu Tomlinson 2008-03-09 16:11:51 UTC
I can't reproduce this with Pidgin, I'm assuming we fixed it


Note You need to log in before you can comment on or make changes to this bug.