Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224180 - Update Request: xchat 2.8.2
Summary: Update Request: xchat 2.8.2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xchat
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact:
URL: http://www.xchat.org/
Whiteboard:
: 226919 (view as bug list)
Depends On:
Blocks: FC7UpdateRequests
TreeView+ depends on / blocked
 
Reported: 2007-01-24 15:20 UTC by Kevin Kofler
Modified: 2018-04-11 06:50 UTC (History)
7 users (show)

Fixed In Version: 2.8.2-8.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-07 16:00:32 UTC


Attachments (Terms of Use)
spec diff (deleted)
2007-01-25 20:06 UTC, Marius Feraru
no flags Details | Diff

Description Kevin Kofler 2007-01-24 15:20:19 UTC
Description of problem:
X-Chat 2.8.0 is out. Rawhide still has 2.6.6.
The main new feature is builtin systray support. The D-Bus support has been 
redone (in 2.6.8) with a new interface and is now builtin (no more dbus.so). 
There were also a few minor bugfixes and improvements, see:
http://www.xchat.org/changelog.txt

Version-Release number of selected component (if applicable):
2.6.6 -> 2.8.0

Additional info:
FC6 RPMs with the Fedora patches are available from:
http://remi.collet.free.fr/index.php?2007/01/15/276-xchat-280-1
(These have been built by Rémi Collet. I've put him in the CC list.) This 
could be of help when preparing the package for Rawhide.

Note also that it should be possible to drop the gnome-open patch, as upstream 
now defaults to xdg-open if it's there, and falls back to gnome-open or 
kfmclient (depending on the running desktop environment) if xdg-open is 
unavailable.

This should also be an unproblematic update for FC6 if it's judged worthwhile. 
Not for FC5, though, because it requires GTK+ 2.10.

Comment 1 Marius Feraru 2007-01-25 20:06:34 UTC
Created attachment 146613 [details]
spec diff

* Thu Jan 25 2007 Marius FERARU <altblue@n0i.net> - 1:2.8.0-1.n0i.1
- version 2.8.0
- disabled some patches: nonblock, locale (fi, es)
- enabled fast tinting
- fixed "exchant" typo
- switched to using the "make install" (DESTDIR works)
- simplified gconf schema disabling method
- dropped plugins mover
- updated "Get rid of static libs"
- dropped xchat-remote
- updated build requirements
- dropped "default-webbrowser" patches (xchat tries to do it better now)
- do not provide "perl.so", "python.so", etc
- own everything under %%{_libdir}/xchat
- converted spec file to UTF8
- fixed desktop entry category (dropping "Application")
- keep plugins documentation

Comment 2 Remi Collet 2007-01-26 06:13:00 UTC
You should add the upstream patches from 
http://xchat.org/files/source/2.8/patches/

Regards


Comment 3 Peter Zelezny 2007-05-15 07:10:09 UTC
Will FC7 only have xchat 2.6.6? That would be a little disappointing.

Comment 4 Kevin Kofler 2007-05-15 07:14:15 UTC
Maybe Rémi should be added as X-Chat comaintainer (or even primary maintainer?) 
now that Core and Extras have merged? That's if he's interested and caillon is 
OK with it, of course.

Unfortunately, I think it's too late now to get the update into F7, at best it 
will get into updates. :-(

Also, 2.8.2 is now out.

Comment 6 Peter Zelezny 2007-05-21 09:56:29 UTC
Ok, it seems Christopher Aillon was little upset I didn't take his patch upstream:
http://sourceforge.net/tracker/index.php?func=detail&atid=100239&aid=1051098&group_id=239
but this patch introduced a couple of bugs. Saying I'm an unresponsive upstream
(as per mailing list thread) is a bit unfair, I havn't got a single email from
any Fedora people, ever. I even read your bugzilla and try help out here and
there :)

P.S I don't see the multiline patch as a show stopper, 2.8.2 without it is still
much better than 2.6.6 with it.

Comment 7 Christopher Aillon 2007-05-21 16:46:24 UTC
Zed, those were not my words.  I just said I lost interest because of that
patch.  I never heard anything about bugs being introduced, so the problem
couldn't be addressed though.

Comment 8 Peter Zelezny 2007-05-31 13:22:44 UTC
Patch worth including for any 2.8.2 update:

http://xchat.org/files/source/2.8/patches/xc282-fixtrayzombies.diff


Comment 9 Kevin Kofler 2007-05-31 13:25:17 UTC
Hmmmph, and I just requested a push to updates-testing. I guess I'll just push 
out a new build with that patch ASAP. Thanks for notifying us! :-)

Comment 10 Kevin Kofler 2007-05-31 13:49:57 UTC
Patch applied in 2.8.2-6.

Comment 11 Kevin Kofler 2007-06-02 13:55:43 UTC
Oops, I forgot to put Christopher Aillon into CC when I reassigned this to 
myself. Rectified now. :-)

I pushed 2.8.2-7 (same as 2.8.2-6 but with the .desktop file reverted to what 
was used in Fedora before at Christopher Aillon's request) to Rawhide and F7 
updates-testing.

I have 1 positive feedback (plus my own testing as well). Chris, any chance you 
can push this for FC6 updates-testing too? I can't push anything to FC6. (Note 
that I'd like at least 1 positive report with input methods before pushing this 
to any released updates, because Warren Togami said some versions caused 
trouble there.)

Comment 12 Fedora Update System 2007-06-04 04:11:29 UTC
xchat-2.8.2-8.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2007-06-07 15:59:52 UTC
xchat-2.8.2-8.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Kevin Kofler 2007-07-25 09:05:18 UTC
*** Bug 226919 has been marked as a duplicate of this bug. ***

Comment 15 Warren Togami 2007-09-18 18:57:27 UTC
NOTE: This update completely broke input methods, making it unusable for Asian
languages.

Comment 16 Kevin Kofler 2007-09-18 19:21:50 UTC
I had the update tested by someone using the Korean SCIM input method and it 
worked for him. (He just tried again with 2.8.4-2.fc7 and it still works for 
him.) I wouldn't have pushed it otherwise. So "completely" is probably the 
wrong word, still this doesn't sound good. Does this break only some input 
methods and not others?

Comment 17 Kevin Kofler 2007-09-18 19:28:02 UTC
See bug 295331 for the regression, let's please keep the discussion in one 
place.


Note You need to log in before you can comment on or make changes to this bug.