Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224132 - LTC31269-HTS-5.0-17: memory test failed
Summary: LTC31269-HTS-5.0-17: memory test failed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 5
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-24 11:33 UTC by Issue Tracker
Modified: 2008-07-16 21:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-22 01:22:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
results.xml from failed memory test - IBM (deleted)
2007-01-25 00:04 UTC, Archana K. Raghavan
no flags Details
esults-memory-bl3-9.xmldl (deleted)
2007-01-26 00:30 UTC, Archana K. Raghavan
no flags Details

Description Issue Tracker 2007-01-24 11:33:07 UTC
Escalated to Bugzilla from IssueTracker

Comment 13 Greg Nichols 2007-01-24 15:03:43 UTC
Please attach the test results (either the results rpm, or /var/hts/results.xml)

- Thanks

Comment 16 Archana K. Raghavan 2007-01-25 00:04:38 UTC
Created attachment 146479 [details]
results.xml from failed memory test - IBM

Comment 17 Greg Nichols 2007-01-25 17:18:52 UTC
(In reply to comment #15)
> Created an attachment (id=146469) [edit]
> failed mem test - results.xml
> 

This run failed stating that the bw_mem command was not found - this is one of
the lmbench tools, and should be in /usr/bin.  Please check this, and also,
what version/revision of lmbench is installed, and where did you obtain it?

- Thanks


Comment 25 Archana K. Raghavan 2007-01-26 00:30:00 UTC
Created attachment 146656 [details]
esults-memory-bl3-9.xmldl

Comment 33 Archana K. Raghavan 2007-02-02 14:21:39 UTC
Spoke to IBM this morning. So, the problem happens only when the memory = 4G. If
its more or less than that, the test passes. So my tests are not valid. Any
updates on this? This is blocking IBM's cert on RHEL 5 System P.

- Archana

Comment 38 Greg Nichols 2007-02-08 21:17:54 UTC
Please try running the threaded_memtest directly, ala:

> cd /usr/share/hts/tests/memory
> make threaded_memtest
> ./threaded_memtest -qpv -m100% -t10

Also try it with a slightly lower memory paramter:

./threaded_memtest -qpv -m95% -t10

- Thanks!

Comment 40 Greg Nichols 2007-02-09 17:02:56 UTC
The problem is that the threaded_memtest binary is compiled as a 32-bit
application.   A work-around for this bug is to set -m64 prior to running 
the test, as in:

> CFLAGS=" -m64 "
> export CFLAGS
> hts certify --test memory



Comment 41 Greg Nichols 2007-02-09 17:52:47 UTC
Fixed R25: threaded_memtest compiles with -m64 on ppc64

Comment 42 Issue Tracker 2007-02-10 14:01:43 UTC
----- Additional Comments From hien1@us.ibm.com  2007-02-09 17:24 EDT
-------
I changed CFLAGS in Makefile, and it worked fine. Running 16GB memory test.
it 
will take long time to run .Will post the results when done. 


This event sent from IssueTracker by araghavan 
 issue 111840

Comment 43 Issue Tracker 2007-02-11 14:50:15 UTC
----- Additional Comments From hien1@us.ibm.com  2007-02-10 12:49 EDT
-------
HTS memory test passed with CFLAGS=-m64 


This event sent from IssueTracker by araghavan 
 issue 111840

Comment 44 Issue Tracker 2007-02-15 20:36:06 UTC
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ACCEPTED                    |CLOSED




------- Additional Comments From hien1@us.ibm.com  2007-02-15 14:58 EDT
-------
Memory test fixed in HTS-5.0-25. 


This event sent from IssueTracker by araghavan 
 issue 111840


Note You need to log in before you can comment on or make changes to this bug.