Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224088 - lvcreate fails when installing into pre-existing volume group with insufficient free space
Summary: lvcreate fails when installing into pre-existing volume group with insufficie...
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Joel Andres Granados
QA Contact:
URL:
Whiteboard:
: 431564 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-24 00:24 UTC by Bryan Mason
Modified: 2008-06-12 12:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-12 12:14:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
Installation log (deleted)
2007-01-24 00:31 UTC, Bryan Mason
no flags Details
Output of "vgdisplay -v" in RHEL4 (deleted)
2007-01-24 00:36 UTC, Bryan Mason
no flags Details

Description Bryan Mason 2007-01-24 00:24:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
I'm trying to install RHEL5-Beta2 into a system that already has RHEL5 installed.  I have free space in a volume group, so I want to create a new logical volume and install RHEL5 into that volume.  I've done this before with RHEL3 and RHEL4 with no problems.

Version-Release number of selected component (if applicable):
anaconda-11.1.2.16-1

How reproducible:
Always


Steps to Reproduce:
1. Start installer.
2. Select manual partitioning.
3. Create new logical volume "LVM_LogVol01" in "VolGrp00" and set as root mount point.  Use existing /boot, and swap partitions.

Actual Results:
Traceback (most recent call first):
  File "/usr/lib/anaconda/fsset.py", line 2312, in setupDevice
    raise SystemError, "lvcreate failed for %s" %(self.name,)
  File "/usr/lib/anaconda/fsset.py", line 1613, in createLogicalVolumes
    entry.device.setupDevice(chroot, vgdevice = vg)
  File "/usr/lib/anaconda/packages.py", line 141, in turnOnFilesystems
    anaconda.id.fsset.createLogicalVolumes(anaconda.rootPath)
  File "/usr/lib/anaconda/dispatch.py", line 199, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 122, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 978, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 243, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1005, in handleRenderCallback
    self.currentWindow.renderCallback()
SystemError: lvcreate failed for LVM_LogVol01


Expected Results:
RHEL5 should have installed.

Additional info:
Will upload entire installation log shortly.

Comment 1 Bryan Mason 2007-01-24 00:31:09 UTC
Created attachment 146382 [details]
Installation log

Comment 2 Bryan Mason 2007-01-24 00:36:13 UTC
Created attachment 146383 [details]
Output of "vgdisplay -v" in RHEL4

Comment 3 Bryan Mason 2007-01-24 01:03:29 UTC
In the timeless words of Emily Litella, "never mind."

As it turns out, there wasn't enough space in the volume group to add a new
logical volume.  There was enough space in the physical volume, but through a
slightly unusual series of events (which I won't go through here), the volume
group was smaller than the physical volume.

size of physical volume    24 GB

  size of volume group     12 GB
- existing logical volume   8 GB
------------------------------
  free space in group       4 GB

I was trying to create a new 8 GB logical volume when there was only 4 GB of
free space in the volume group.  Once I increased the size of the volume group
to the size of the underlying physical volume, RHEL5 installs fine.

So I guess the real error was that anaconda didn't warn me that there wasn't
enough free space in the volume group.

(Emily Litella: http://en.wikipedia.org/wiki/Emily_Litella)

Comment 4 Joel Andres Granados 2008-04-18 16:10:53 UTC
*** Bug 431564 has been marked as a duplicate of this bug. ***

Comment 5 Joel Andres Granados 2008-06-12 11:17:36 UTC
FYI, I duped them because the tracebacks where equal


Note You need to log in before you can comment on or make changes to this bug.