Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224086 - NetworkManager brings up wired network when no wired is connected.
Summary: NetworkManager brings up wired network when no wired is connected.
Keywords:
Status: CLOSED DUPLICATE of bug 194124
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-24 00:21 UTC by Steve Dickson
Modified: 2018-04-11 09:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-21 05:25:07 UTC


Attachments (Terms of Use)

Description Steve Dickson 2007-01-24 00:21:03 UTC
Description of problem:
When logging into my T60 laptop the NetworkManager Applet (version 
0.6.4) will bring up the wired connection when there is nothing 
connect to the interface. I would expect NM should bring up the 
wireless connection since there is only one network available... 

After wired connection (incorrectly) brought up, I click on
the wireless network which brings down the wired connection
and brings up the wireless connection as expected. 

The wired interface is a Intel e1000
The wireless interface is a Intel ipw3945

The wired interface that has no connection 
is configure like:

eth0      Link encap:Ethernet  HWaddr 00:15:58:2E:22:22  
          inet addr:169.254.182.22  Bcast:169.254.255.255 Mask:255.255.0.0
          inet6 addr: fe80::215:58ff:fe2e:2222/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:96 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:24204 (23.6 KiB)

Version-Release number of selected component (if applicable):


How reproducible:
Everytime 

Steps to Reproduce:
1. log in
2.
3.
  
Actual results:


Expected results:


Additional info:
ifcfg-eth0 (wired):
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:15:58:2E:22:22
ONBOOT=no
TYPE=Ethernet
USERCTL=yes
IPV6INIT=no
PEERDNS=yes

ifcfg-eth1 (wirless)
TYPE=Wireless
DEVICE=eth1
HWADDR=00:13:02:9a:25:29
BOOTPROTO=dhcp
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
ONBOOT=no
USERCTL=no
IPV6INIT=no
PEERDNS=yes
ESSID=
CHANNEL=1
MODE=Managed
RATE='36 Mb/s'

Comment 1 Matěj Cepl 2007-01-30 01:52:49 UTC
Could be there some delay in activation of binary-only {drivers,dameon}? I have
similar problems with ndiswrapper-driven BCM4318, but I blame Broadcomm for not
providing documentation.

Comment 2 Dan Williams 2007-06-21 05:25:07 UTC

*** This bug has been marked as a duplicate of 194124 ***


Note You need to log in before you can comment on or make changes to this bug.