Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224085 - kernel-2.6.19-1.2895.fc6 errors in compile
Summary: kernel-2.6.19-1.2895.fc6 errors in compile
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 6
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-24 00:14 UTC by Dave Feldbauer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-24 08:46:33 UTC


Attachments (Terms of Use)

Description Dave Feldbauer 2007-01-24 00:14:48 UTC
Description of problem:after install kernel update 2.6.19-1.2895.fc6 (updating
from 2.6.18-1.2869.fc6) I tried to remake network drivers for realtek rtl8187l
usb wireless card.  I have compiled these drivers in the older kernel and they
compiled and worked.  Now on compile i get this error 

/r8187_core.c:2421: error: ‘struct net_device’ has no member named
‘get_wireless_stats’
when trying to compile the drivers



Version-Release number of selected component (if applicable):

kernel-2.6.19-1.2895.fc6 
i686
How reproducible:

Every time

Steps to Reproduce:
1.compile drivers from Realtek rtl8187_linux_26.1010.zip
2.
3.
  
Actual results:

compiling exits with errors

/r8187_core.c:2421: error: ‘struct net_device’ has no member named
‘get_wireless_stats’
when trying to compile the drivers
Expected results:
drivers should compile

Additional info:

please contact for any additional logs or info

Comment 1 Jakub Jelinek 2007-01-24 08:46:33 UTC
That doesn't sound like a gcc bug, simply you downloaded some outdated kernel
module sources that is incompatible with recent changes in the kernel.


Note You need to log in before you can comment on or make changes to this bug.