Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224083 - pdksh does not load ~/.profile
Summary: pdksh does not load ~/.profile
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pdksh
Version: 4.4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-23 23:10 UTC by Chris Naude
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-24 09:41:48 UTC


Attachments (Terms of Use)

Description Chris Naude 2007-01-23 23:10:30 UTC
Description of problem:


Version-Release number of selected component (if applicable):
Version 5.2.14
Release 30.3

How reproducible:
Every time I login this occurs

Steps to Reproduce:
1. Create ~/.profile with custom settings
2. Switch to ksh or login with ksh
3. 
  
Actual results:
The ~/.profile is never read

Expected results:
The ~/.profile needs to be sourced according to the man pages

Additional info:

Comment 1 Karsten Hopp 2007-01-24 09:41:48 UTC
How are you testing this ?
Please note that you either need to set your login shell to /bin/ksh with the
chsh command or you need to start ksh with the '-l' parameter to make it a login
shell.

Both ways work for me on RHEL-4.4 with pdksh-5.2.14-30.3
p.e.
> cat ~/.profile
echo running $HOME/.profile
> ksh -l
running /home/karsten/.profile
>

Comment 2 Chris Naude 2007-01-24 15:26:26 UTC
I created another LDAP account and it works as it's supposed to. I tested it on
several other machines and it works correctly. The issue seems to be specific to
one LDAP account on one machine. Thanks for your assistance.


Note You need to log in before you can comment on or make changes to this bug.