Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224079 - lvm(8) can leave a truncated /etc/lvm/.cache file
Summary: lvm(8) can leave a truncated /etc/lvm/.cache file
Keywords:
Status: CLOSED DUPLICATE of bug 224078
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: LVM and device-mapper development team
QA Contact: Corey Marthaler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-23 22:54 UTC by Kurtis D. Rader
Modified: 2007-11-17 01:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-24 01:19:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Kurtis D. Rader 2007-01-23 22:54:41 UTC
The lvm(8) family of commands can leave a truncated /etc/lvm/.cache file if the 
root filesystem becomes full while the file is being written. If the system is 
rebooted at that point it will fail to boot because the subsequent vgscan(8) 
will croak when it attempts to parse the incomplete cache file.

The problem is that the persistent_filter_dump() function does not check the 
return value of any of the writes or fclose(). In fact, simply checking the 
return value of the fclose() and not renaming the temporary file if the close 
fails should be sufficient. This obviously assumes persistent_filter_dump() has 
already been augmented to write to a temporary file and call rename() before 
returning (a change that has already been submitted).

Comment 1 Kurtis D. Rader 2007-01-23 23:07:29 UTC
This is a dup of bug#224078. I submitted it twice because bugzilla gave me an 
error about

    product " is not valid

(or some such).

Comment 2 Dave Wysochanski 2007-01-24 01:19:06 UTC

*** This bug has been marked as a duplicate of 22078 ***

Comment 3 Dave Wysochanski 2007-01-24 01:19:42 UTC
*** This bug has been marked as a duplicate of 224078 ***

*** This bug has been marked as a duplicate of 224078 ***


Note You need to log in before you can comment on or make changes to this bug.