Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224069 - matplotlib 0.87.7.3 broken against numpy 1.0.1-2. Compiled against different numpy version.
Summary: matplotlib 0.87.7.3 broken against numpy 1.0.1-2. Compiled against different ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: python-matplotlib
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-23 21:26 UTC by Mark Heslep
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-23 22:45:04 UTC


Attachments (Terms of Use)
MPL RuntimeError exception (deleted)
2007-01-23 21:26 UTC, Mark Heslep
no flags Details

Description Mark Heslep 2007-01-23 21:26:31 UTC
Description of problem:
Current mpl is compiled against a newer version of numpy than is available in
the current extras; mpl 0.87.7.3.fc6 is binary incompatible with current numpy
1.0.1-2.fc6. Running most of the provided mpl examples produces the error:
"""
RuntimeError: module compiled against version 1000009 of C-API but this version
of numpy is 1000002
...
"""

Version-Release number of selected component (if applicable):
0.87.7.3.fc6


How reproducible:
Every time.

Steps to Reproduce:
1.Install numpy and matplotlib
2.run matplotlib provided example such as logo.py
3.
  
Actual results:
see attachment

Expected results:
execute example without throwing RuntimeError or ImportError

Additional info:

Comment 1 Mark Heslep 2007-01-23 21:26:31 UTC
Created attachment 146359 [details]
MPL RuntimeError exception

Comment 2 Jef Spaleta 2007-01-23 22:12:39 UTC
I cant reproduce this.  
/usr/share/doc/python-matplotlib-0.87.7/examples
python logo.py

works as expected for me. No errors and I get the logo in a plot window named
Figure 1.

python-matplotlib-0.87.7-3.fc6
numpy-1.0.1-2.fc6

What arch are you on?

I have been using python-matplotlib everyday now for a couple of weeks on
multiple x86 cpus to run a series of spectral analysis python scripts. 

-jef

Comment 3 Mark Heslep 2007-01-23 22:45:04 UTC
Arg, sorry, disregard.  Had an additional numpy installed locally where a local
PYTHONPATH found it. Closing.


Note You need to log in before you can comment on or make changes to this bug.