Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224040 - aquamarine: new windows crash window decorator/manager
Summary: aquamarine: new windows crash window decorator/manager
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: aquamarine
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jarod Wilson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-23 19:20 UTC by Rex Dieter
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: aquamarine-0.1.99.2-1.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-30 18:54:56 UTC


Attachments (Terms of Use)

Description Rex Dieter 2007-01-23 19:20:24 UTC
Under kde-3.5.6, using beryl + aquamarine, launching any new app/window crashes
window decorator/manager.  Seems to be the same as upsteam report:
http://bugs.beryl-project.org/ticket/578

Using Standard/Emerald window decorator, things are happy (but I really miss the
kde decoration and features).

Comment 1 Jarod Wilson 2007-01-30 16:39:02 UTC
I pushed 0.1.99.2 beryl bits through the build system yesterday, but I haven't
yet had a chance to try out aquamarine to see if this is fixed.

Comment 2 Rex Dieter 2007-01-30 18:47:09 UTC
Missing beryl-dbus?
Error: Missing Dependency: beryl-dbus >= 0.1.99.2 is needed by package beryl-gnome


Comment 3 Rex Dieter 2007-01-30 18:48:02 UTC
# rpm -e beryl-gnome beryl
allowed me to continue, and update the other bits.

Comment 4 Rex Dieter 2007-01-30 18:54:56 UTC
Yay, confirmed no more (instant) crashes on new app/window launch.

Comment 5 Jarod Wilson 2007-01-30 19:35:47 UTC
(In reply to comment #2)
> Missing beryl-dbus?
> Error: Missing Dependency: beryl-dbus >= 0.1.99.2 is needed by package beryl-gnome
> 

Crap. beryl-dbus was rolled back into beryl-plugins upstream. I have
beryl-plugins  obsoleting beryl-dbus, but forgot to have it provide it as well.
I'll fix that in a sec...

Glad to hear aquamarine is working though! :)


Note You need to log in before you can comment on or make changes to this bug.