Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224016 - tons of "expire_indirect: fstat failed: Bad file descriptor" messages
Summary: tons of "expire_indirect: fstat failed: Bad file descriptor" messages
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: autofs
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ian Kent
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-23 17:25 UTC by Ulrich Drepper
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: autofs-5.0.1-0.rc3.16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-14 07:39:22 UTC


Attachments (Terms of Use)

Description Ulrich Drepper 2007-01-23 17:25:26 UTC
Description of problem:
I see tons of

  automount[2717]: expire_indirect: fstat failed: Bad file descriptor

messages in /var/log/messages.  Every 1 or 2 minutes.  I'm not adding that many
new mounts so I can only assume that autofs does not remove the descriptor after
fstat failed.  If fstat return EBADF there is no reason whatsoever to keep it
around.  If the descriptor becomes usable again at some point it is for
something else and then the fstat can only give incorrect information.

I doubt that autofs should get into this situation in the first place (no idea
what happened) but at least handle the situation more graceful if the problem is
detected.  Otherwise you fill up /var/log/messages and cause greater harm by
hijacking a descriptor.

Version-Release number of selected component (if applicable):
autofs-5.0.1-0.rc3.6.x86_64

How reproducible:
don't know

Steps to Reproduce:
1.don't really know.  create situation where descriptor is gone
2.
3.
  
Actual results:
tons of such messages

Expected results:
exactly one such message

Additional info:

Comment 1 Jeff Moyer 2007-01-23 19:40:29 UTC
Hmm, the file descriptor is the ioctl fd.  Either ioctlfd is getting corrupted,
or we're trying to expire an already expired mount?  Can you attach a copy of
your maps please?

Comment 2 Ulrich Drepper 2007-01-23 19:44:46 UTC
I'm using the default maps, nothing changed at all.  And the only map I use
/etc/auto.net via /net/HOSTNAME/some/dir.  That's it.

Comment 3 Ian Kent 2007-01-24 01:58:12 UTC
(In reply to comment #2)
> I'm using the default maps, nothing changed at all.  And the only map I use
> /etc/auto.net via /net/HOSTNAME/some/dir.  That's it.

Can you grab autofs-5.0.1-0.rc3.10 and give it a try please.

Ian

Comment 4 Ulrich Drepper 2007-01-24 06:41:54 UTC
I've downloaded it an will use it.  I cannot remember having seen the problem
before so it might be not so easy to confirm the problem is gone.  If you think
it is fixed I think it's best to close the bug and I'll reopen it in case I see
it again.

Comment 5 Ian Kent 2007-01-24 06:58:39 UTC
(In reply to comment #4)
> I've downloaded it an will use it.  I cannot remember having seen the problem
> before so it might be not so easy to confirm the problem is gone.  If you think
> it is fixed I think it's best to close the bug and I'll reopen it in case I see
> it again.

I had two other reports that I believe where the same problem.
Both reporters have have posted that it appears to be fixed.

I'm fairly sure it was introduced by a patch I added on the 27th
Dec to fix another issue.

It won't hurt to leave this open for a while longer to give you
a chance to check it out.

Ian


Comment 6 Ian Kent 2007-02-14 07:39:22 UTC
(In reply to comment #4)
> I've downloaded it an will use it.  I cannot remember having seen the problem
> before so it might be not so easy to confirm the problem is gone.  If you think
> it is fixed I think it's best to close the bug and I'll reopen it in case I see
> it again.

No time to check this out?
I'll close this as you recommend.

Ian



Note You need to log in before you can comment on or make changes to this bug.