Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223992 - Warzone2100 - code not clean for x86_64
Summary: Warzone2100 - code not clean for x86_64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: warzone2100
Version: 9
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karol Trzcionka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 245540 335711 384321 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-23 14:58 UTC by Karol Trzcionka
Modified: 2008-06-26 20:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-26 20:15:43 UTC


Attachments (Terms of Use)

Description Karol Trzcionka 2007-01-23 14:58:49 UTC
The Warzone2100 is not prepare to build and work on x86_64. I contacted with
developers and the problem should be fixed in next version, but it will be
probably "in the last half of this year.". I will be checking the svn, but I
have not any access to x86_64 machine. 
The logs of building are here:
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=145190
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=145270

Comment 1 Francois Aucamp 2007-01-24 07:37:12 UTC
Just for some clarification, the problem is basically the (old and infamous)
method of storing 64-bit pointers in 32-bit integers. However, since warzone2100
was originally a Windows-based application, it makes extensive use of DWORD,
UDWORD, etc, macros, which now only serves to obfuscate things even more.

Given the size of the source code, cleaning this up is a big(ish) task.

Comment 2 David Woodhouse 2007-06-25 10:10:41 UTC
*** Bug 245540 has been marked as a duplicate of this bug. ***

Comment 3 Karol Trzcionka 2007-10-17 14:49:08 UTC
*** Bug 335711 has been marked as a duplicate of this bug. ***

Comment 4 Karol Trzcionka 2007-11-18 22:01:18 UTC
*** Bug 384321 has been marked as a duplicate of this bug. ***

Comment 5 Michael Ploujnikov 2008-02-18 16:27:39 UTC
I was able to compile the latest beta release in Fedora 8.
Info about the beta release:
http://forums.wz2100.net/?topic=1391.0
Source that I used to for compilation:
http://download.gna.org/warzone/releases/2.1/warzone2100-2.1_beta1.tar.bz2

Comment 6 Oliver Falk 2008-03-10 10:55:42 UTC
Great. Latest version in F-8 works (on alpha)!

Comment 7 Fedora Update System 2008-04-22 18:52:44 UTC
warzone2100-2.1.0-0.5.beta2.fc8 has been submitted as an update for Fedora 8

Comment 8 Fedora Update System 2008-04-29 20:58:03 UTC
warzone2100-2.1.0-0.5.beta2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update warzone2100'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-3381

Comment 9 Bug Zapper 2008-05-14 02:33:59 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 10 Fedora Update System 2008-05-17 22:22:01 UTC
warzone2100-2.1.0-0.5.beta2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.