Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223989 - php-oci8 from source rpm compile issue
Summary: php-oci8 from source rpm compile issue
Keywords:
Status: CLOSED DUPLICATE of bug 162241
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: php
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-23 14:41 UTC by Alexandre CUILLERIER
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-02 13:16:58 UTC


Attachments (Terms of Use)
compilation log file (deleted)
2007-01-23 14:47 UTC, Alexandre CUILLERIER
no flags Details

Description Alexandre CUILLERIER 2007-01-23 14:41:17 UTC
Description of problem:
unable to compile php with oci8 from source rpm

Version-Release number of selected component (if applicable):
php-4.3.9-3.9.src.rpm

How reproducible:
always, it seems

Steps to Reproduce:
1. download php source rpm package, 
2. make oracle-instant-client rpms from binary backages (as seen there:
http://remi.collet.free.fr/index.php?2006/06/24/166-oracle-instant-client -
sorry it's in french)
3. compile with rpmbuild -bb whateveroci8/oracle/define...parameter
/usr/src/redhat/SPEC/php.spec
(--define "_with_oci8 1" gives better results)
  
Actual results:
see log attached
doesn't compile with oci8 module option activated.

Expected results:
oci8 module for php and complete build of rpms

Additional info:

Comment 1 Alexandre CUILLERIER 2007-01-23 14:47:54 UTC
Created attachment 146300 [details]
compilation log file

re-adding log file, couldn't see it

Comment 2 Alexandre CUILLERIER 2007-01-23 17:29:13 UTC
Solution found !!!

the source rpm includes an oci8 patch which is not applied by the .spec file.
This little patch (please be gentle, it's my first one : "diff -urN oldfile
newfile" ) seems to make the compilation with oci8 option work!

content of the patch (I named it: php-4.3.9-spec-RHEL4.oci8.patch):
"
--- php.spec    2006-11-02 22:26:49.000000000 +0100
+++ php.spec.patched       2007-01-23 17:28:21.000000000 +0100
@@ -37,6 +37,7 @@
 Patch23: php-4.3.9-curlpost.patch
 Patch24: php-4.3.8-gdnspace.patch
 Patch25: php-4.3.2-curlsafemode.patch
+Patch26: php-4.3.9-oci8.patch

 # Functional changes
 Patch30: php-4.3.1-dlopen.patch
@@ -330,6 +331,7 @@
 %patch23 -p1 -b .curlpost
 %patch24 -p1 -b .gdnspace
 %patch25 -p1 -b .curlsafemode
+%patch26 -p1 -b .oci8

 %patch30 -p1 -b .dlopen
 %patch31 -p1 -b .easter
"
which I applied with command:
# patch -p0 <php-4.3.9-spec-RHEL4.oci8.patch

Then compile php this way:
# rpmbuild -bb --define "_with_oci8 1" php.spec

Comment 3 Joe Orton 2007-02-02 13:16:58 UTC

*** This bug has been marked as a duplicate of 162241 ***


Note You need to log in before you can comment on or make changes to this bug.