Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223984 - Zone transfers fail - wrong perm/ownership on /var/named/chroot/var/named
Summary: Zone transfers fail - wrong perm/ownership on /var/named/chroot/var/named
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bind
Version: 4.4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Adam Tkac
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-23 14:20 UTC by Tethys
Modified: 2013-04-30 23:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-05 15:53:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tethys 2007-01-23 14:20:42 UTC
Description of problem:
Jan 23 12:31:48 springfield named[11310]: received notify for zone 'example.com'
Jan 23 12:32:03 springfield named[11310]: zone example.com/IN: refresh: failure
trying master 89.106.176.217#53: timed out 
Jan 23 12:32:18 springfield named[11310]: zone example.com/IN: refresh: failure
trying master 89.106.176.217#53: timed out 
Jan 23 12:32:18 springfield named[11310]: dumping master file: tmp-XXXXPSW7dI:
open: permission denied
Jan 23 12:32:18 springfield named[11310]: transfer of 'example.com/IN' from
89.106.176.217#53: failed while receiving responses: permission denied
Jan 23 12:32:18 springfield named[11310]: transfer of 'example.com/IN' from
89.106.176.217#53: end of transfer

Version-Release number of selected component (if applicable):
bind-9.2.4-16.EL4

How reproducible:
Every time

Steps to Reproduce:
1. Set up bind as a slave.
2. Update the master
3. Watch the slave fail to update...


Additional info:

An strace shows it to be failing to write a temporary file to the current
directory (which is /var/named/chroot/var/named). That directory is owned
by root, and not writeable by the named user. A "chown named" fixed it
(I could have changed the permissions instead, but no user other than
named should ever really need to write to that directory anyway, so
chown seemed like the best bet). That fixed the problem, and the slave
was updated correctly.

Comment 1 Tethys 2007-01-23 18:21:13 UTC
Sigh. This is not a bug, just a case of RH being different...

/etc/init.d/named was changing ownership of that directory back to root.

If I tell named to write the zone file to the slaves directory (to play
nicely with selinux) then it all seems to work.

Comment 4 Adam Tkac 2007-02-05 15:27:45 UTC
(In reply to comment #1)

So if I understand correctly can I close this like notabug?


Comment 5 Tethys 2007-02-05 15:50:11 UTC
Yes, you can.

Comment 6 Adam Tkac 2007-02-05 15:53:30 UTC
closing


Note You need to log in before you can comment on or make changes to this bug.