Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223971 - [kn_IN] Consonant + Halant + Consonant + Dependent Vowel not appearing properly in some rare cases
Summary: [kn_IN] Consonant + Halant + Consonant + Dependent Vowel not appearing proper...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: fonts-indic
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rahul Bhalerao
QA Contact:
URL:
Whiteboard:
: 223970 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-23 12:38 UTC by Ramakrishna Reddy Yekulla
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-30 06:16:36 UTC


Attachments (Terms of Use)
The Actually results of the words. (deleted)
2007-01-23 12:38 UTC, Ramakrishna Reddy Yekulla
no flags Details
The *Expected* result. (deleted)
2007-01-23 12:39 UTC, Ramakrishna Reddy Yekulla
no flags Details
Side by side comparison with new font. (deleted)
2007-02-09 10:59 UTC, Mayank Jain
no flags Details
Verified Image (deleted)
2007-04-30 06:15 UTC, A S Alam
no flags Details

Description Ramakrishna Reddy Yekulla 2007-01-23 12:38:36 UTC
Description of problem:
Halant + Consonant + Dependent Vowel not appearing properly in some cases, the
ligaure rules need to be changed and some anchor points neend to be added in the
right places. This occurs during the formation of certain words.

Version-Release number of selected component (if applicable):

fonts-kannada-2.0.12-1.fc7

How reproducible:
Every time

Steps to Reproduce:
1. gedit
2. Activate SCIM
3. Select SCIM-inscript
4. Input the following keysequence, look for the complex conjuct combinations
(RAW UNICODE provided)
**********************************
ಚಂದಾದಲ್ಲಿ :: ;xoeondnf ::  ಲ್ಲಿ  -  0CB2 + OCCD +0CB2 + 0CBF
ಲಿನಕ್ಸ್ :: nfvkdmd  :: ಕ್ಸ್   - 0C95 + 0CCD + 0CB8 
ಕ್ಲೈಂಟ್ :: kdnwx'd :: ಕ್ಲೈ  0C95 + 0CCD + 0CB2 + 0CC8
ಅಪ್ಗ್ರೇಡ್ :: Dhdidjs[d :: ಪ್ಗ್ರೇ - 0CAA + 0CCD + 0C97 + 0CCD + 0CB0 + 0CC0
ತಂತ್ರಜ್ಞಾನ :: lxldj%ev :: ಜ್ಞಾ - 0C9C +0CCD +  0C9E + 0CBE 
ಪರೀಕ್ಷಿಸಲು :: hjr&fmng :: ಕ್ಷಿ -  0C95 + 0CCD + 0C97 + 0CBF
  
Actual results:

Attached as a screenshot.

Expected results:

Attached as a Screenshot.

Additional info:

Comment 1 Ramakrishna Reddy Yekulla 2007-01-23 12:38:36 UTC
Created attachment 146289 [details]
The Actually results of the words.

Comment 2 Ramakrishna Reddy Yekulla 2007-01-23 12:39:52 UTC
Created attachment 146290 [details]
The *Expected* result.

Comment 3 Parag Nemade 2007-01-29 05:06:55 UTC
*** Bug 223970 has been marked as a duplicate of this bug. ***

Comment 8 Parag Nemade 2007-02-19 10:42:30 UTC
This fix has been included in next release of fonts-indic package =>
fonts-kannada-2.1.3-1.fc7.noarch.rpm

Comment 9 A S Alam 2007-04-30 06:15:57 UTC
Created attachment 153761 [details]
Verified Image

Comment 10 A S Alam 2007-04-30 06:16:36 UTC
CLOSE:
verified with following package:
fonts-kannada-2.1.5-1.fc7


Note You need to log in before you can comment on or make changes to this bug.