Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223964 - Galeon on x86_64 does not search /usr/lib64/mozilla/plugins, uses /usr/lib
Summary: Galeon on x86_64 does not search /usr/lib64/mozilla/plugins, uses /usr/lib
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: galeon
Version: 6
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Denis Leroy
QA Contact: Fedora Extras Quality Assurance
URL: about:plugins
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-23 11:43 UTC by Jan Pazdziora
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-28 17:41:44 UTC


Attachments (Terms of Use)
fix for correct loading of plugins on 64-bit platforms (deleted)
2007-01-27 17:51 UTC, Dan Horák
no flags Details | Diff
new spec file for FC6 (deleted)
2007-01-27 17:52 UTC, Dan Horák
no flags Details
x86_64 mozilla plugin path fix (deleted)
2007-01-27 20:48 UTC, Denis Leroy
no flags Details | Diff

Description Jan Pazdziora 2007-01-23 11:43:28 UTC
Description of problem:

When you install a 64-bit plugin, it gets installed to
/usr/lib64/mozilla/plugins. However, the about:plugins page does not show the
plugin (and the plugin is not used).

Version-Release number of selected component (if applicable):

galeon-2.0.3-4.fc6.1

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have 64-bit galeon installed.
2. Install 64-bit plugin, for example nspluginwrapper.
3. Check that the plugin got installed to /usr/lib64's subdirectory, not to
/usr/lib, which seems like a sensible thing to do.
4. Go to about:plugins.

Actual results:

The plugin is not shown.

Expected results:

The plugin should be shown.

Additional info:

Creating symlinks from /usr/lib/mozilla/plugins/* to those appropriate 64-bit
files in /usr/lib64/mozilla/plugins makes them to work, however, this should
work out of box and not search (32-bit) /usr/lib.

Comment 1 Dan Horák 2007-01-27 12:20:31 UTC
The problem is in file mozilla/mozilla-embed-shell.cpp (function
mozilla_init_plugin_path) where the search path for plugins is created.

Quick and dirty solution I am using for codeblocks:
- patch the file to use @libdir@/mozilla/plugins instead of /usr/lib/mozilla/plugins
- in the prep section run "sed -i s|@libdir@|%{_libdir}|g
mozilla/mozilla-embed-shell.cpp"

Comment 2 Dan Horák 2007-01-27 17:51:36 UTC
Created attachment 146747 [details]
fix for correct loading of plugins on 64-bit platforms

Comment 3 Dan Horák 2007-01-27 17:52:52 UTC
Created attachment 146748 [details]
new spec file for FC6

Comment 4 Denis Leroy 2007-01-27 20:48:21 UTC
Created attachment 146751 [details]
x86_64 mozilla plugin path fix

Dan,

Your patch is not correct: @foo@-type substitutions are done by automake. To
make this work, you'd need a AC_SUBST() statement as well as a
mozilla-embed-shell.cpp.in file. There's a simpler way to do this, as galeon
already passes down configuration paths through -D compiler flags. Could you
verify that the attached patch works on your x86_64 system ?

many thanks!

Comment 5 Dan Horák 2007-01-27 21:26:07 UTC
The @foo@ substitutions are usually done when running configure (they are
contained in the foo.in files) and I am doing it manually with sed called from
the %prep section of the spec file which could be a bit confusing. But your
solution is much better and it works too.

Comment 6 Denis Leroy 2007-01-27 22:21:39 UTC
Ah ok sorry, I missed the spec file sed. Will build and close.



Note You need to log in before you can comment on or make changes to this bug.