Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223962 - disklessrc can only use eth0. Added diff for fix.
Summary: disklessrc can only use eth0. Added diff for fix.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-netboot
Version: 4.4
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Jaroslav Reznik
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-23 11:17 UTC by Gerben Roest
Modified: 2010-04-06 11:18 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-06 11:18:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Gerben Roest 2007-01-23 11:17:53 UTC
Description of problem:

disklessrc only configures eth0. If pxe-booted from (what turns out to be) e.g.
eth1, the netbooting stops and you get a simple bash prompt.


Version-Release number of selected component (if applicable):

0.1.40


How reproducible:

always


Steps to Reproduce:
1. put utp cable in netboot-client, in eth port that won't be eth0
2. pxe boot
3. 
  
Actual results:

simple bash prompt, no network


Expected results:

full net boot, root over nfs.


Additional info:

I have changed disklessrc so that it can use other eth devices than only eth0.
It may be a bit quick and/or dirty, but it works for me. This is the diff (added
indents and "\" for readability). The < is my version, > is old version.

195c195
< /bin/dhclient -1 -pf /tmp/dhclient.pid -lf /tmp/dhclient.leases \ 
    >/tmp/dhclient.out 2>&1
---
> /bin/dhclient -1 -cf /tmp/dhclient.conf -pf /tmp/dhclient.pid -lf \
    /tmp/dhclient.leases $ETHERNET >/tmp/dhclient.out 2>&1
231c231,233
< IP=$(ip addr show|grep "inet "|grep -v 127|awk '{ print $2 }' |awk -F/ '{ \
    print $1 }')
---
> IP=`/sbin/ip addr show ${ETHERNET} scope global primary | 
>     grep '^[\ \      ]*inet.*scope global '${ETHERNET} |
>     sed 's/^.*inet\ //;s/[\/\ ].*$//'`;

Comment 1 Gerben Roest 2007-01-23 11:22:29 UTC
I understand that you CAN use other interfaces but you have to tell the client
that via the ETHERNET variable in the pxe boot conf. With my fix it doesn't
matter where you put your utp cable, as long as the machine can pxe boot from it.
Some Opteron boards use eth0 for the e100 and eth1 and eth2 for the tg3 driver.
This triggered me to create this fix.

Comment 3 Jaroslav Reznik 2010-04-06 11:18:26 UTC
System-config-netboot is now in maintenance mode only, no further development
is planned for RHEL 4.x. Closing as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.