Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223952 - IMP rpm should require php-pear-Mail
Summary: IMP rpm should require php-pear-Mail
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: imp
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brandon Holbrook
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-23 08:55 UTC by Mark Wormgoor
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-28 21:06:42 UTC


Attachments (Terms of Use)

Description Mark Wormgoor 2007-01-23 08:55:20 UTC
Description of problem:
The imp rpm does not require php-pear-Mail. However, it is needed for sending
and receiving e-mail.

Version-Release number of selected component (if applicable):
imp-4.1.3-4.fc6@noarch

How reproducible:
Install horde+imp when you don't have any pear packages installed yet.

Steps to Reproduce:
1. Use package manager (smart/yum) to install horde+imp
2. Try sending e-mail (won't work, because Mail.php and Mail/RFC822.php are missing.
  
Actual results:
[23-Jan-2007 09:47:13] PHP Fatal error:  IMP::require_once() [<a
href='function.require'>function.require</a>]: Failed opening required
'Mail/RFC822.php' (include_path='/usr/share/horde/lib:.:/usr/share/pear') in
/usr/share/horde/imp/lib/IMP.php on line 356
[23-Jan-2007 09:47:23] PHP Warning:  IMP_Compose::require_once(Mail.php) [<a
href='function.IMP-Compose-require-once'>function.IMP-Compose-require-once</a>]:
failed to open stream: No such file or directory in
/usr/share/horde/imp/lib/Compose.php on line 82

Expected results:
E-mail should send without PHP errors.

Additional info:
N/a

Comment 1 Brandon Holbrook 2007-01-28 21:06:42 UTC
Good catch, Mark.  It's been fixed in 4.1.3-5


Note You need to log in before you can comment on or make changes to this bug.