Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223950 - My ES1869 chip died with kernel
Summary: My ES1869 chip died with kernel
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
Depends On:
TreeView+ depends on / blocked
Reported: 2007-01-23 08:28 UTC by Linus Walleij
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-01-23 09:02:51 UTC

Attachments (Terms of Use)

Description Linus Walleij 2007-01-23 08:28:35 UTC
Description of problem:
My ES1869 chip died when upgrading to kernel

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot into the newly pushed kernel
2. The ES1869 is stone dead, no sound whatsoever.
Actual results:
Driver does not work (it loads) these come from dmesg:
es18xx: unable to grap ports 0x220-0x22f
pnp: Device 00:0b disabled.
es18xx-pnpbios: probe of 00:0b failed with error -16

Expected results:
Worked fine with kernel-2.6.18-1.2869.fc6

Additional info:
This is a chip on the ISA bridge, not detected so needed special
hacks in /etc/modprobe.conf. I get the feeling ISA PNP was enabled
but doesn't quite work...

Here is a copy of my modprobe.conf:

# ALSA portion
alias char-major-116 snd
options snd-es18xx enable=1 isapnp=0 port=0x220 mpu_port=0x330 fm_port=0x388 irq
=5 dma1=1 dma2=0
# OSS/Free portion
alias char-major-14 soundcore
# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
remove snd-es18xx { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/mo
dprobe -r --ignore-remove snd-es18xx
alias snd-card-0 snd-es18xx
options snd-card-0 index=0

Comment 1 Linus Walleij 2007-01-23 09:02:51 UTC
This was easily solved .. :-P

Remove all modprobe.conf crap and let PNP do its work, magically
it works (after some poking at the ALSA interfaces).

Sorry for this premature bug report.

Note You need to log in before you can comment on or make changes to this bug.