Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223932 - /etc/init.d/halt uses of kexec shuts down the network too soon
Summary: /etc/init.d/halt uses of kexec shuts down the network too soon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts
Version: 5.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
: 228814 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-23 05:00 UTC by Mike Christie
Modified: 2014-03-17 03:05 UTC (History)
8 users (show)

Fixed In Version: RHBA-2007-0663
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 19:11:34 UTC


Attachments (Terms of Use)
pass kexec -x (deleted)
2007-01-23 05:00 UTC, Mike Christie
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0663 normal SHIPPED_LIVE initscripts and hotplug bug fix update 2007-10-30 15:11:01 UTC

Description Mike Christie 2007-01-23 05:00:09 UTC
Description of problem:

For reboot, /etc/init.d/halt calls kexec which turns off the network interfaces.
If MD, DM, LVM, or some other layer, was using a iscsi device this causes a hang
of the reboot. During the kernel shutdown/reboot, a device's driver model
shutdown function is called and for scsi/iscsi this function can try to send a
cache sync command (it depends on the target and/or device if the command is
needed and sent or not so this is why we do not always see a problem). When the
scsi layer sends the command, the iscsi layer will not have a good connection
because the interface has been brought down by kexec and the reboot/shutdown
sequence will wait forever for this command to complete (userspace is not up so
the iscsi error handle cannot do anything).

This is the same problem we had with /sbin/halt being passed -i.

Version-Release number of selected component (if applicable):


How reproducible:

Every time with certain targets like IET.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

The uploaded patch modifies /etc/init.d/halt's kexec usage so the network
interfaces are not turned off like was done for /sbin/halt.

Comment 1 Mike Christie 2007-01-23 05:00:09 UTC
Created attachment 146267 [details]
pass kexec -x

Comment 2 Andrius Benokraitis 2007-02-19 23:11:04 UTC
*** Bug 228814 has been marked as a duplicate of this bug. ***

Comment 3 Amit Bhutani 2007-02-21 01:26:06 UTC
Sounds like a higher severity issue than "normal". Raising severity accordingly.

Comment 4 Amit Bhutani 2007-02-21 01:28:34 UTC
Oops, just realized that this was not the Dell opened bug but rather the RH
opened one. Didn't mean to step on somebodies foot and raise the severity.
Please reset severity if you (Mike/Andrius) disagree.

Comment 5 Andrius Benokraitis 2007-02-21 13:24:52 UTC
Amit, raising priority for this would be acceptable since more than one party
has seen this, and is imapacting Dell. Thanks!

Comment 6 RHEL Product and Program Management 2007-04-25 22:11:01 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 8 Bill Nottingham 2007-06-22 22:02:34 UTC
Building in 8.45.16.EL-1.

Comment 9 Harald Hoyer 2007-06-29 09:31:55 UTC
Test-RPMS could be downloaded from
http://people.redhat.com/harald/downloads/initscripts/initscripts-8.45.16.EL-1/

Comment 12 errata-xmlrpc 2007-11-07 19:11:34 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0663.html



Note You need to log in before you can comment on or make changes to this bug.