Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223916 - Guest install of Windows Server 2003 requires manually rebooting into 2nd stage
Summary: Guest install of Windows Server 2003 requires manually rebooting into 2nd stage
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager
Version: 5.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Daniel Berrange
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-23 01:10 UTC by Bryn M. Reeves
Modified: 2008-01-28 15:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-31 16:21:28 UTC


Attachments (Terms of Use)

Description Bryn M. Reeves 2007-01-23 01:10:46 UTC
+++ This bug was initially created as a clone of Bug #214707 +++

RHEL5.0.0 version of this bug is closed CURRENTRELEASE with documentation in the
release notes - this bug is to track the fix in 5.1.0.

Description of problem:
I'm attempting to install Windows Server 2003 EE SP1 as a guest on a fully-virt
RHEL5 Beta system.

The regular install is in two stages:
(i) stage 1 is a rather primitive text mode that asks a few questions, then lays
down a partition with a C:\ with some basic files on it.  It then shuts down (I
believe it's asking the BIOS for a reboot)
(ii) stage 2 is a graphical installer that performs configuration and the rest
of the install

When I perform an install, stage 1 works, and it shuts down.  When this happens
the graphical console window closes, and the guest disappears from
virt-manager's list of machines, and the following appears at the terminal
(32, 'Broken pipe')

I'd expect it to detect that a reboot was attempted (if indeed W2003 is asking
for this), and automatically reboot the guest system.  The graphical console
window should stay open (preserving its location on my desktop) and I should be
able to continue the install.

The workaround for now is to type the following at the terminal:
xm create /etc/xen/<NAME-OF-GUEST-MACHINE>
and then "Open" the virtual machine

Version-Release number of selected component (if applicable):
xen-3.0.3-6.el5
virt-manager-0.2.5-1.el5
kernel-xen-2.6.18-1.2740.el5
Windows Server 2003 Enterprise Edition SP1 as guest

How reproducible:
100%

Additional info:
This was added to the GA release notes under "Known Issues":

-- Additional comment from ddomingo@redhat.com on 2006-12-14 23:33 EST --
Windows Server 2003 guest install bug: Installing Windows Server 2003 as a guest
on a fully virtualized Red Hat Enterprise Linux 4.92 system ends unexpectedly
after completing the first stage of installation. When this happens, the
graphical console window closes, and the guest disappears from the Virtual
Machine Manager's list of machines, resulting in a Broken pipe error.

This issue will be resolved in an upcoming Red Hat Enterprise Linux 4.92 update.
To work around this, use the following command at the terminal:

xm create /etc/xen/<name of guest machine>

Afterwards, open the virtual machine.
</quote>

Comment 1 Daniel Berrange 2007-01-31 16:21:28 UTC

*** This bug has been marked as a duplicate of 223442 ***


Note You need to log in before you can comment on or make changes to this bug.