Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223904 - Image on web page not showing up
Summary: Image on web page not showing up
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 6
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2007-01-22 23:17 UTC by Rodney Lancaster
Modified: 2018-04-11 10:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-09-11 11:57:32 UTC

Attachments (Terms of Use)

Description Rodney Lancaster 2007-01-22 23:17:35 UTC
Description of problem: Image not showing up in Firefox on FC6 i686 system.

Version-Release number of selected component (if applicable):
uname -a output: Linux 2.6.18-1.2869.fc6 #1 SMP Wed Dec 20
14:51:19 EST 2006 i686 i686 i386 GNU/Linux
Firefox version: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:
Gecko/20061219 Fedora/ Firefox/ pango-text

How reproducible: Very.

Steps to Reproduce:
1.Start firefox
2.Go to web page:
3.At the bottom of the page just above the "Create Using:" and an image for Open
Office, there is "Hosted by:" and there is supposed to be an image for Hosted by
1&1".  However on FC6 with Firefox it does not show up.  Using firefox it shows up fine.
Actual results:
firefox does not show the image.
firefox 2.0 does not show the image.
firefox shows the image fine.

Expected results:
1and1 image should show on all firefox browsers.

Additional info:

Comment 1 Andre Robatino 2007-01-23 00:38:47 UTC
  I see the image on a fully updated FC6 i686 box using firefox-

Comment 2 Rodney Lancaster 2007-01-23 04:58:58 UTC
I just updated using 'yum update' and rebooted. Should be fully updated as well.
Still no 1and1 logo.

uname -a output: Linux 2.6.19-1.2895.fc6 #1 SMP Wed Jan 10
19:28:18 EST 2007 i686 i686 i386 GNU/Linux

Firefox: firefox-

Any other ideas?

Comment 3 Andre Robatino 2007-01-23 05:23:09 UTC
  When you say that it does not show the image, do you see an icon for a missing
image, or nothing at all?  Also, I just checked the Google cache for the page
(the page itself is not accessible for me at the moment) and the link for the
image is

Can you see the image using this link directly?

Comment 4 Rodney Lancaster 2007-01-27 03:38:22 UTC
The link shows up fine, directly.  However, the following test page code, using
the recommended link code from does not.

<P ALIGN=CENTER>Hosted by: <A HREF=""
NAME="1and1Graphics2" ALT="1and1 Banner" ALIGN=BOTTOM WIDTH=140 HEIGHT=28

Comment 5 Andre Robatino 2007-01-27 03:45:49 UTC
  I'm not familiar with HTML, but you should be able to strip out some of this
to create a simplest possible test case, and then fiddle with it to see if you
can find exactly what is causing the image to be hidden.

Comment 6 Rodney Lancaster 2007-01-28 22:35:40 UTC
I haven't found the offending item, yet.  

It is interesting to note that this code snippit works fine on firefox
on Ubuntu Linux and on Firefox 2.0 on Windows XP.

Comment 7 Rodney Lancaster 2007-01-28 23:30:36 UTC
I saved the gif file to my home directory.  Replacing the source with the URL:
file:///home/rlancas/banner.gif worked even with the entire snippet from

I then took a look at the 3 special characters in the original URL.  The "?",
"&" (%26), and % (%25).  I don't think that is the problem, however, since the
same snippet works fine on firefox on Ubuntu Linux and Firefox on
Windows XP.  I wish I had access to the XML code at to check and seeh
what they are doing to return the gif file.  Anyway, I copied the file
banner.gif to bann?er&%.gif and tried to load it like the URL has specified as
file:///home/rlancas/bann?er%26%25.gif.  It would not load.  When I went and did
a File -> Open and selected the file bann?er&%.gif it came in as
bann%3Fer&%25.gif.  Not an exact test since there is still XML code in between.
 However, based on this short test could the ? somehow be passed incorrectly
from the screen input?

Needless to say, I'm still confused but willing to try other tests if you need
me to.

Comment 8 Matěj Cepl 2007-01-29 17:07:55 UTC
Weird, I can reproduce it on RHEL5 with firefox- and I cannot
reproduce it with epiphany-2.16.0-4.fc6 using the same Gecko library (using
--nodeps and symlink /usr/lib/firefox- -> /usr/lib/firefox- ) In
the same time (URL of
the image) shows just fine in firefox.

Comment 9 Christopher Aillon 2007-01-29 18:03:10 UTC
Images go through system libraries, e.g. libpng, libjpeg, etc.  Maybe one of
those is the culprit.

Comment 10 Martin Stransky 2007-09-11 11:57:32 UTC
Works for me (FF2.0&F7).

Note You need to log in before you can comment on or make changes to this bug.