Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223881 - No display generated by X server after installation
Summary: No display generated by X server after installation
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-22 21:56 UTC by Bruce Orchard
Modified: 2018-04-11 13:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-12 19:21:58 UTC


Attachments (Terms of Use)
/etc/X11/xorg.conf generated by anaconda. Note that the video driver is vesa. (deleted)
2007-01-22 21:56 UTC, Bruce Orchard
no flags Details
Output from lspci (deleted)
2007-01-22 22:28 UTC, Bruce Orchard
no flags Details
Output from lspci -n (deleted)
2007-01-22 22:29 UTC, Bruce Orchard
no flags Details
/etc/sysconfig/hwconf (deleted)
2007-01-22 22:30 UTC, Bruce Orchard
no flags Details
log when running with nv driver at 800x600 (deleted)
2007-01-29 21:21 UTC, Bruce Orchard
no flags Details

Description Bruce Orchard 2007-01-22 21:56:29 UTC
Description of problem:




How reproducible:
every time

Steps to Reproduce:
1.do an installation

  
Environment:
Dell Dimension C521
Nvidia GeForce 6150LE
Dell 2007 LCD display

After installation, during boot, when the X server is activated by rhgb, no
display is generated.  Instead the monitor displays an error message:  "Out of
range signal.  Cannot display this video mode.  Change computer display input to
1600x1200@60Hz"


Expected results:

The boot display should have been displayed.

Comment 1 Bruce Orchard 2007-01-22 21:56:30 UTC
Created attachment 146237 [details]
/etc/X11/xorg.conf generated by anaconda.  Note that the video driver is vesa.

Comment 2 Bruce Orchard 2007-01-22 22:28:56 UTC
Created attachment 146247 [details]
Output from lspci

Comment 3 Bruce Orchard 2007-01-22 22:29:08 UTC
Created attachment 146248 [details]
Output from lspci -n

Comment 4 Bruce Orchard 2007-01-22 22:30:18 UTC
Created attachment 146249 [details]
/etc/sysconfig/hwconf

Comment 5 Chris Lumens 2007-01-26 15:22:46 UTC
From my quick 30 second check on a machine with FC6 still installed, it looks
like 10DE:0241 was listed in /usr/share/hwdata/videoaliases/nv.xinf, but was
commented out.  The same file has it uncommented on rawhide.  This would mean
that FC6 anaconda/rhpxl/kudzu doesn't know what driver to assign for that
device, hence it picks vesa and that's what you get in the xorg.conf.

I'm sending this one over to the X driver guys for further comment.

Comment 6 Bruce Orchard 2007-01-29 17:38:12 UTC
I tried changing the video driver in /etc/X11/xorg.conf from vesa to nv.  That
did produce a display, but it would only run at 800x600.

Comment 7 Adam Jackson 2007-01-29 19:53:41 UTC
Do you have an X log from starting with nv?  Would be interesting to know why
it's limited to 800x600.

Comment 8 Bruce Orchard 2007-01-29 21:21:28 UTC
Created attachment 146872 [details]
log when running with nv driver at 800x600

The monitor is a Dell 2007FP, which is capable of 1600x1200.

Comment 9 Adam Jackson 2007-03-01 21:15:04 UTC
So, vesa should be working with this setup now.

The 800x600 limitation appears to be due to non-functional DDC.  You will want
to set the HorizSync and VertRefresh values for your display in xorg.conf.

Comment 10 Adam Jackson 2007-03-12 19:21:58 UTC
Please update to xorg-x11-drv-vesa 1.3.0-4 or later, and reopen if this is still
an issue for you.


Note You need to log in before you can comment on or make changes to this bug.