Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223877 - Crash on entering address into To field
Summary: Crash on entering address into To field
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-22 21:28 UTC by Andrew Overholt
Modified: 2008-08-02 23:40 UTC (History)
0 users

Fixed In Version: 2.8.3-1.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-03 15:53:53 UTC


Attachments (Terms of Use)
bug-buddy report (deleted)
2007-01-22 21:28 UTC, Andrew Overholt
no flags Details

Description Andrew Overholt 2007-01-22 21:28:33 UTC
Description of problem:
Composing mail messages frequently (almost always) crashes all of Evolution. 
bug-buddy doesn't finish because it claims that the app (it think it's the
calendar) doesn't track its bugs in Gnome bugzilla.

Version-Release number of selected component (if applicable):
evolution-2.8.2.1-3.fc6.i386
evolution-data-server-1.8.2-2.fc6.i386

How reproducible:
90% of the time.

Steps to Reproduce:
1. Compose a mail
2. Type something into the To: field
  
Actual results:
Crash of all of Evolution.

Expected results:
No crash :)

Additional info:
I've attached what bug-buddy wanted to submit.  I can install debuginfo packages
as necessary.  I've got two IMAP accounts set up and my homedir is on NFS.

Comment 1 Andrew Overholt 2007-01-22 21:28:33 UTC
Created attachment 146232 [details]
bug-buddy report

Comment 2 Matthew Barnes 2007-04-03 03:47:51 UTC
Thanks for the bug report and apologies for not getting to this sooner.

Are you still seeing these crashes in FC6?  What about in FC7Test3?

If you could install evolution-debuginfo and evolution-data-server-debuginfo,
and then post another backtrace if and when you see the crash again that would
be very useful to me.  From your first backtrace I'm guessing that an error
occurred while reading contact information, and as a result of poor error
handling in Evolution an invalid pointer is being passed to a strcmp() call,
which is enough to crash a program.  But debuginfo packages would help me know
for sure.

Comment 3 Andrew Overholt 2007-04-03 15:53:53 UTC
(In reply to comment #2)
> Thanks for the bug report and apologies for not getting to this sooner.

Not a problem.

> Are you still seeing these crashes in FC6?  What about in FC7Test3?

I haven't been seeing in rawhide so I had been ignoring my FC6 box where I had
the troubles.  However, trying just now I can't duplicate anymore.  Sweet.  The
machine evidently now has:

evolution-2.8.3-1.fc6.i386
evolution-data-server-1.8.3-1.fc6.i386

Thanks.


Note You need to log in before you can comment on or make changes to this bug.