Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223838 - Canna server will not start
Summary: Canna server will not start
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Canna
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 235591 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-22 18:16 UTC by Jerry James
Modified: 2007-12-18 05:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-12-18 05:47:53 UTC


Attachments (Terms of Use)

Description Jerry James 2007-01-22 18:16:55 UTC
Description of problem:
After installing canna, "service canna start" produces this message:
Starting Canna server: cannaserver: -u flag specified, but canna not run as root
                                                           [FAILED]

Version-Release number of selected component (if applicable):
Canna-3.7p3-16.fc6

How reproducible:
Always

Steps to Reproduce:
1. Install Canna
2. service canna start (or reboot)
  
Actual results:
The Canna server fails to start.

Expected results:
The Canna server should start.

Additional info:

Comment 1 Akira TAGOH 2007-02-15 13:43:58 UTC
Well, sorry, it looks like there are no canna user in your box, which means
%post somehow failed during the installation.

Please make sure if canna user has been added. if not, please attach the
installation log if you have. it would be helpful to solve your problem.

Comment 2 Akira TAGOH 2007-02-15 13:45:00 UTC
Oops, I meant %pre, but anyway ;)

Comment 3 Jerry James 2007-02-22 03:52:51 UTC
I found the problem.  Once upon a time, I had openais installed.  It created a
user named "ais" with ID 39.  When I uninstalled it, apparently it left user ais
behind.  Anyway, the entry is still in /etc/passwd.  So when the Canna package
tried to create user 39, it failed.  You should probably check whether openais
still wants uid 39; if so, either it or the Canna package will have to change
the requested uid.

Deleting the ais user manually and reinstalling Canna did the trick.  Thanks!

Comment 4 Akira TAGOH 2007-04-09 09:24:18 UTC
*** Bug 235591 has been marked as a duplicate of this bug. ***

Comment 5 Ville Skyttä 2007-08-13 12:39:53 UTC
Note that http://fedoraproject.org/wiki/PackageUserCreation is not the official
package user/group creation guideline doc -
http://fedoraproject.org/wiki/PackagingDrafts/UsersAndGroups is (currently
ratified, pending for writeup in the packaging guidelines)

Comment 6 Akira TAGOH 2007-08-13 12:57:24 UTC
Aha. thanks for your info.

Comment 7 Akira TAGOH 2007-08-20 09:23:05 UTC
should be fixed in 3.7p3-21.fc6.

Comment 8 A S Alam 2007-12-18 05:47:53 UTC
it is fixed and showing no error, tested with following package:
Canna-3.7p3-22.fc9


Note You need to log in before you can comment on or make changes to this bug.