Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223807 - mutt-1.4.2.2-5.fc6.i386.rpm depends on /usr/sbin/sendmail instead of smtpdaemon
Summary: mutt-1.4.2.2-5.fc6.i386.rpm depends on /usr/sbin/sendmail instead of smtpdaemon
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mutt
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-22 16:10 UTC by Leo Baltus
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-22 17:22:24 UTC


Attachments (Terms of Use)

Description Leo Baltus 2007-01-22 16:10:21 UTC
Description of problem:
As of mutt-1.4.2.2-5.fc6.i386.rpm a dependency is changed from smtpdaemon to
/usr/sbin/sendmail

Version-Release number of selected component (if applicable):


How reproducible:
always: install mutt-1.4.2.2-5.fc6.i386.rpm

Steps to Reproduce:
1. rpm -qip --requires mutt-1.4.2.2-5.fc6.i386.rpm
2. rpm -qip --requires mutt-1.4.2.2-4.fc6.i386.rpm
  
Actual results:
1: /usr/sbin/sendmail
2: smtpdaemon  

Expected results:
smtpdaemon

Additional info:
the smtpdaemon dependency was there to have a generic dependency, this breaks 
installation where an mta is beeing used which does not provide /usr/sbin/sendmail.

Comment 1 Miroslav Lichvar 2007-01-22 16:19:08 UTC
Which mta that would be? mutt doesn't connect to a smtp daemon, it uses
/usr/sbin/sendmail.

Comment 2 Leo Baltus 2007-01-22 16:39:44 UTC
Well, any mta for all I care. 

Better still is to have no dependency on any mta at all since it is
configurable, but since there is one I would rather have a generic depedency
rather than this specific one /usr/sbin/sendmail.

Comment 3 Miroslav Lichvar 2007-01-22 16:57:44 UTC
The dependency is more general, all packages in Core + Extras that provide
smtpdaemon provide also /usr/sbin/sendmail. mutt-1.4.2.2-5.fc6 doesn't require a
smtp deamon, so you can have only esmtp installed.



Comment 4 Leo Baltus 2007-01-22 17:22:24 UTC
Ah, I was not amaware of this package, thank you for pointing this out to me.



Note You need to log in before you can comment on or make changes to this bug.