Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223806 - NFSv4 rpciod waiting on sync task! kernel 2.6.9-42
Summary: NFSv4 rpciod waiting on sync task! kernel 2.6.9-42
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.4
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
: ---
Assignee: Jeff Layton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-22 15:56 UTC by Dannis
Modified: 2007-11-17 01:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-17 19:55:28 UTC


Attachments (Terms of Use)

Description Dannis 2007-01-22 15:56:29 UTC
NFSv4, often client crash one at three times per day and
I see this error in log "rpciod waiting on sync task!", 
It's not a really crash, but it's similar, because the user can't do nothing
and other users can't login to the station, but root can if Ctrl C is pushed at 
login. lsof doesn't work and tcpdump show nothing bad.

I see a similar problem on bugzilla and Steve Dickson said that it will be 
fixed in the upcoming release of RHEL4.
But I can't go to the bug
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=194793 

Version-Release number of selected component (if applicable):
We are using NFSv4 on RedHat 4 Enterprise kernel 2.6.9-42
All clients and servers run on kernel 2.6.9-42, but servers and clusters are 64-
bit

How reproducible:
I can reproduce the bug with the software subversion on a CVS folder.

Additional info:
Is it a problem with socket ?
Is it a problem with open lock file on NFS ?

Comment 1 Ronald Cole 2007-03-08 03:07:15 UTC
I'm seeing the same thing.  kernel 2.6.9-42.0.8.  NFSv4 server and clients are
64-bit.  And I can't go to that bug, either.  Sure wish there were at least a
workaround!

Comment 2 Ronald Cole 2007-03-08 03:13:54 UTC
Oh yeah, the rpciod process on the client is in state "D".  Is there a known bug
where this process gets deadlocked?

Comment 3 Jeff Layton 2007-07-17 19:53:43 UTC
I believe I have a patch going into 4.6 that should fix this problem. If you
have a non-critical place to do so, please test the kernels on my people page
and let me know if they resolve the issue:

http://people.redhat.com/jlayton


Comment 4 Jeff Layton 2007-07-17 19:55:28 UTC

*** This bug has been marked as a duplicate of 228292 ***


Note You need to log in before you can comment on or make changes to this bug.